PDA

Visualizza la versione completa : [Java] Cambiare compilatore ad eclipse


dybart
16-02-2005, 13:39
Ho scaricato la versione 1.5 di jsdk e vorrei utilizzarla come compilatore di default su eclipse installato sulla mia macchina linux..
Sinceramemte non ho ben chiaro quale sia il porcedimento... Qualcuno potrebbe spiegarmi come fare?
Grazie a tutti per l'attenzione

unomichisiada
16-02-2005, 13:52
Originariamente inviato da dybart
Ho scaricato la versione 1.5 di jsdk e vorrei utilizzarla come compilatore di default su eclipse installato sulla mia macchina linux..
Sinceramemte non ho ben chiaro quale sia il porcedimento... Qualcuno potrebbe spiegarmi come fare?
Grazie a tutti per l'attenzione
Se hai installato solo quella jdk ed eclipse parte stai già usando il compilatore di quella jdk visto che eclipse è scritto in java,altrimenti nemmeno partirebbe...

dybart
16-02-2005, 13:59
Originariamente inviato da unomichisiada
Se hai installato solo quella jdk ed eclipse parte stai già usando il compilatore di quella jdk visto che eclipse è scritto in java,altrimenti nemmeno partirebbe...
No no.. Il fatto è che avevo installato eclipse in precedenza ed ora ho messo la 1.5... Ora come ora lavora con la 1.4.1 iche si è installato solo...

unomichisiada
16-02-2005, 14:38
Originariamente inviato da dybart
No no.. Il fatto è che avevo installato eclipse in precedenza ed ora ho messo la 1.5... Ora come ora lavora con la 1.4.1 iche si è installato solo... Permettimi di dubitare,eclipse non installa alcuna jdk,sfrutta quella già installata nel sistema,se non ci credi prova a disinstallarle entrambe e a far partire eclipse.Comunque tutto ciò che devi fare è disinstallare le due jdk ed eclipse (basta cancellare la cartella) e reinstallare nell'ordine,la jdk 1.5 --> eclipse

dybart
16-02-2005, 15:49
Ti ringrazio seguirò la procedura che mi hai consigliato..

unomichisiada
17-02-2005, 21:42
Mi devo scusare,ho provato ad aggiornare la mia jdk alla 1.5 e con la procedura che ti ho detto non sono riuscito a far partire eclipse (con jdk meno recenti funziona però).Il problemasi risolve comunque molto semplicemente lanciando eclipse con l'opzione per specificare il percorso della jdk, da me:
eclipse -vm C:\Programmi\Java\jdk1.5.0\bin\javaw
Ciao

netarrow
17-02-2005, 22:46
se crei un nuovo progetto java, clicchi sul destro sopra all'iconcina che rappresenta il JDK e su "configure" clicchi
su "alternate jdk" o roba del genere. Quindi fai "search installed jdk" o qualcosa di simile, eclipse ti mostrerà le versioni installate e potrai scegliere se usare la vecchia 1.4 o la 5.

Almeno questo su Eclipse 3.0 su win.

:ciauz:

netarrow
17-02-2005, 22:48
Originariamente inviato da dybart
...
Ora come ora lavora con la 1.4.1 iche si è installato solo
...


questo è sembrato anche a me, ho passato Eclipse ad un mio amico che aveva solo il JRE, eppure eclipse compilava

:ciauz:

unomichisiada
18-02-2005, 01:22
Originariamente inviato da netarrow
questo è sembrato anche a me, ho passato Eclipse ad un mio amico che aveva solo il JRE, eppure eclipse compilava

:ciauz:
Allora avevo torto marcio anche su quello.comunque almeno una jre serve già installata altrimenti non parte nemmeno,questo è sicuro perchè ho provato.Ciao ciao

Loading