PDA

Visualizza la versione completa : netgear WG511 su Debian


Lucis
16-02-2005, 19:14
Ciao a tutti, sto provando a far funzionare una scheda wireless PCMCIA Netgear WG511 sul portatile che ha
una Debian Sarge con kernel 2.6.10 (kernel-image-2.6.10-1-686).

Sto seguendo le istuzioni all'url http://prism54.org/phpwiki?pagename=Prism54%20Debian%20HowTo e sono arrivato a questa situazione:

- i moduli necessati vengono caricati:

root@pclo2:~# lsmod
(...)
pci_hotplug 34448 0
prism54 58824 0
firmware_class 10144 1 prism54
(...)

- ho copiato il firmware (versione 1.0.4.3) nella directory /usr/lib/hotplug/firmware/ rinominandolo isl3890:


root@pclo2:~# ls /usr/lib/hotplug/firmware/
isl3890


quando per inserisco la scheda, nel syslog:


Feb 16 19:51:11 localhost kernel: PCI: Enabling device 0000:03:00.0 (0000 -> 0002)
Feb 16 19:51:11 localhost kernel: ACPI: PCI interrupt 0000:03:00.0[A] -> GSI 11 (level, low) -> IRQ 11
Feb 16 19:51:11 localhost pci.agent[8100]: prism54: already loaded


e quando do il comando ifconfig eth1 up:

root@pclo2:~# ifconfig eth1 up
SIOCSIFFLAGS: Timer expired


appare nel syslog:


Feb 16 19:51:26 localhost kernel: eth1: resetting device...
Feb 16 19:51:26 localhost kernel: eth1: uploading firmware...
Feb 16 19:51:26 localhost kernel: eth1: firmware version: 1.0.4.3
Feb 16 19:51:26 localhost kernel: eth1: firmware upload complete
Feb 16 19:51:27 localhost kernel: eth1: no 'reset complete' IRQ seen - retrying
Feb 16 19:51:28 localhost kernel: eth1: no 'reset complete' IRQ seen - retrying
Feb 16 19:51:28 localhost kernel: eth1: interface reset failure
Feb 16 19:51:28 localhost kernel: prism54: Your card/socket may be faulty, or IRQ line too busy :(


un problema di interrupt?


root@pclo2:~# cat /proc/interrupts
CPU0
0: 2290232 XT-PIC timer
1: 5109 XT-PIC i8042
2: 0 XT-PIC cascade
5: 10455 XT-PIC Intel ICH4, Intel 82801DB-ICH4 Modem
7: 4 XT-PIC parport0
8: 1 XT-PIC rtc
9: 0 XT-PIC acpi
11: 180603 XT-PIC yenta, uhci_hcd, uhci_hcd, uhci_hcd, ehci_hcd, ohci1394, eth0, nvidia
12: 66 XT-PIC i8042
14: 12220 XT-PIC ide0
15: 4543 XT-PIC ide1
NMI: 0
LOC: 0
ERR: 0
MIS: 0


in effetti l'undicesimo affollato, ma se questo come posso risolvere il problema?

Grazie
:ciauz:

Lucis
18-02-2005, 02:23
ma che bello il forum dalla scheda wireless!!!!!!!!!! :zizi: :zizi: :zizi: :zizi:

[ok, scusate l'entusiasmo... :fighet:]

alla fine ho lasciato perdere il modulo prism54 e ho fatto una disperata prova con ndiswrapper e ha funzionato tutto!
E' abbastanza facile, si compila e installa, poi gli dici dove trovare il driver per xp (il .inf per intenderci) e ti trovi un bel modulo miracoloso!

unbelievable!

[alla faccia di quegli antipatici di linuxant...]

:ciauz:

Loading