PDA

Visualizza la versione completa : Aggiornamento gcc


Arcanoid
17-02-2005, 09:57
Ciao!
Mi hanno appena chiesto di aggiornare gcc (da 3.2 a 3.4) su un server abbastanza importante e vorrei sapere a quali rischi vado incontro.
La distribuzione dovrebbe essere Red Hat o Mandrake.
Oltre al gcc devo aggiornare altro?
Posso farlo senza causare un interruzione dei servizi troppo lunga?

Grazie.

andy caps
17-02-2005, 10:57
:bh: a me sembra un operazione notevolmente pericolosa

con una distro compilata interamente con il gcc precedente mettere gcc 3.4 rischia di rendere instabile il sistema
specialmente con le distribuzioni rpm based
sarebbe consigliabile aggiornare il sistema ad una release piu recente
l'nterruzione sarebbe minima i pacchetti che richiede sono questi pare

andy:/# rpm -q --requires gcc
binutils >= 2.15.92.0.2-1mdk
gcc-cpp = 3.4.3-3mdk
libgcc >= 3.3.2-5mdk
/sbin/install-info
/usr/sbin/update-alternatives
glibc-devel >= 2.2.5-14mdk
rpmlib(VersionedDependencies) <= 3.0.3-1
/bin/sh
/bin/sh
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
bash
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.3)
andy:/#

Arcanoid
17-02-2005, 11:16
La mia preoccupazione per le dipendenze a catena che poi andrebbero risolte.
Ad esempio per binutils dovrei aggiornare libbinutils2 e libopcodes pi altre librerie.
Se arrivo a librerie usate dagli attuali servizi le cose si metteranno male!!!

Ikitt
17-02-2005, 11:18
Originariamente inviato da Arcanoid
Mi hanno appena chiesto di aggiornare gcc (da 3.2 a 3.4) su un server abbastanza importante e vorrei sapere a quali rischi vado incontro.


Un'eventuale installazione in parallelo sarebbe percorribile?

Arcanoid
17-02-2005, 11:31
In che senzo?
Intendi forse l'installazione su un server di prova per verificarne il funzionamento?

Ikitt
17-02-2005, 11:44
Originariamente inviato da Arcanoid
In che senzo?
Intendi forse l'installazione su un server di prova per verificarne il funzionamento?
Beh, quella, potendo, sarebbe sempre buona pratica.
Pero', stavo pensando piuttosto a tener installato sia gcc 3.2 sia gcc 3.4.


Ora che ci ripenso, se ben ricordo c'e' stato almeno un cambio di ABI tra gcc 3.2 e 3.4: in sostanza le librerie compilate con la versione 3.2 non funzionerebbero con binari compilati con la versione 3.4. Non ricordo se cio coinvolgeva solo il supporto C++ o tutto l'insieme. Ti conviene verificare.

Loading