PDA

Visualizza la versione completa : problema con http


jonny83
17-02-2005, 11:24
Ciao Ho un problema con il servizio httpd.

Ho installato un sistema linux Red Hat 9 e tutto funzionava correttamente.

Ieri stato spento in modo non corretto schiacciando il pulsane, (altre volte e capitato ma non era mai successo niente).
Stavolta quando parte non avvia il servizio httpd,

Quando provo a avviarlo a mano mi da questo errore:
http:httpd could not dtermin the server fully qualified domain name, using 127.0.0.1 for server name.

Cosa successo?

Cosa vuol dire questo errore?

Ho provato a riscirver l'http.conf ma non cambia niente.
Cosa devo fare?

Grazie
Ciao

sopadj1
17-02-2005, 11:53
come lo riavvii?

posta il tuo http.conf

jonny83
17-02-2005, 12:36
Originariamente inviato da sopadj1
come lo riavvii?

posta il tuo http.conf

Uso un tool di KDE ma ho provato anche da terminale.
da terminale non mi da nessun errore ma non lo avvia.

Non riesco a postarti http.con troppo grosso, la riga servername e attiva
ServerName localhost

Adesso ho fatto alcune prove e mi dice quando provo ad avviarlo

mi da avvio fallito e basta non mi da nessuna spiegazione di errore

Cosa devo fare??

sopadj1
17-02-2005, 12:46
edita il file http.conf, trova la riga

ServerName blablabla

e mettici

ServerName 127.0.0.1

poi dai il comando

/etc/init.d/apache restart

oppure

/etc/init.d/httpd restart

oppure

apachectl restart

ora non so come funziona nella redhat

facci sapere

:ciauz:

jonny83
17-02-2005, 15:49
Originariamente inviato da sopadj1
edita il file http.conf, trova la riga

ServerName blablabla

e mettici

ServerName 127.0.0.1

poi dai il comando

/etc/init.d/apache restart

oppure

/etc/init.d/httpd restart

oppure

apachectl restart

ora non so come funziona nella redhat

facci sapere

:ciauz:

Ho risolto
E' stato cambiato nel file network il riferimento a localhost,
mentre nel file hosts era rimasto 127.0.0.1 localhost localhost.localdomain localhost
Cos ho cambiato i localost con il nuovo nome, ho sistemato httpd.conf con il nuovo nome e il servizio httpd partito correttamente.

Mi potreste spiegare i campi del file host:
12.0.0.1(ip) localhost(nome associato all'ip) localhost.localdomain(?) localhost(?)

Grazie ciao

sopadj1
17-02-2005, 15:58
si infatti anche come hai fatto tu va bene uguale....

per quanto riguarda la sintassi del file /etc/hosts DOVREBBE essere

ip nome_host nome_host.nome_dominio

Loading