PDA

Visualizza la versione completa : Montare la Partizione FAT32


maxguiso
17-02-2005, 20:43
Niente da fare lo stesso problema anche iserendo al boot quelle stringhe di numero.
Sono cosi retrocesso un po' indietro con le distribuzioni e sono donuto arrivare alla Red Hat 8 per non avere quel problema. Poi ho provato a reinstallare sopra la Fedora 1 (senza aggiornare) ed è andato tutto liscio. Il perche non lo so!
Cosi finalmente ho montato la mia partizione FAT 32 di windows su Linux, il problema è che la voglio montata sempre e per fare questo so che devo il file /etc/fstab, ma non so come si fa. Potete aiutarmi? Una cosa curiosa non riesco ad lanciare fdisk, e ciò mi accadeva già anche l'altro HDD.
Ciao Grazie e a presto

francofait
17-02-2005, 20:50
Originariamente inviato da maxguiso
Niente da fare lo stesso problema anche iserendo al boot quelle stringhe di numero.
Sono cosi retrocesso un po' indietro con le distribuzioni e sono donuto arrivare alla Red Hat 8 per non avere quel problema. Poi ho provato a reinstallare sopra la Fedora 1 (senza aggiornare) ed è andato tutto liscio. Il perche non lo so!
Cosi finalmente ho montato la mia partizione FAT 32 di windows su Linux, il problema è che la voglio montata sempre e per fare questo so che devo il file /etc/fstab, ma non so come si fa. Potete aiutarmi? Una cosa curiosa non riesco ad lanciare fdisk, e ciò mi accadeva già anche l'altro HDD.
Ciao Grazie e a presto


/dev/hda1 /winme vfat user,auto,owner,exec,umask=000,rw 0 0

così :ciauz: :ciauz:

maxguiso
27-02-2005, 12:34
Ho provato ad inserire questi comandi ma niente, non va mi dice permesso negato

aristarkos
27-02-2005, 16:00
Cosi finalmente ho montato la mia partizione FAT 32 di windows su Linux

Non ho capito se il tuo problema è il montaggio automatico al boot o l'accesso di un utente non-root a una partizione FAT32 già montata.

Se si tratta della prima cosa, basta inserire la riga ke ti ha postato francofait in /etc/fstab e ad ogni avvio il filesystem indicato viene montato automaticamente.

Nell'altro caso si tratta di una questione un po' delicata.. Dipende molto dalla distribuzione e dai parametri che metti sulla riga dell'fstab. Io con una Gentoo ho dovuto provare parecchie decine di combinazioni prima di trovare quella che effettivamente funzionasse: se ti serve fammi sapere che ti posto la mia..

roxy1974
27-02-2005, 17:52
ma la cartella /winme che diritti ha? , forse la soluzione sta li'

chaosd
27-02-2005, 18:31
/dev/hda2 /mnt/hd vfat defaults,rw,exec,users,umask=000 1 0

così va per forza, perchè dà il permesso a tutti gli utenti; io avevo lo stesso problema e l'ho risolto così

maxguiso
28-02-2005, 11:00
Allora io ho creato una nuova directory dove montare la partizione, poi l’ho chiaramente montata su quella directory. Il problema è che dopo un reboot non è più visibile. Io vorrei averla sempre li pronta ad ogni avvio. So che bisogna intervenire su qualche file ma non so come operare. Io ho installato Linux Fedora

aristarkos
28-02-2005, 16:41
Originariamente inviato da maxguiso
Il problema è che dopo un reboot non è più visibile. Io vorrei averla sempre li pronta ad ogni avvio.

Ad ogni avvio, INIT, che gestisce il processo di boot, monta in automatico tutti i filesystem elencati nel file /etc/fstab a meno che tra le opzioni di questi ultimi non sia stata specificata l'opzione noauto.
Quindi ti conviene controllare che la corrispondente riga di fstab ci sia e che non sia stata involontariamente specificata l'opzione.
Come riga va benissimo quella che ha postato chaosd..

maxguiso
28-02-2005, 17:46
Quindi devo accedere come utente root e dare il comando:
cat /bin/laden > /dev/null
giusto? Scusate ma sono alle primissime armi con Linux e non so veramente niente

virusbye
28-02-2005, 17:49
Originariamente inviato da maxguiso
Quindi devo accedere come utente root e dare il comando:
cat /bin/laden > /dev/null
giusto? Scusate ma sono alle primissime armi con Linux e non so veramente niente

io c'ero

Loading