PDA

Visualizza la versione completa : [mdk10.1] /boot


christian78
17-02-2005, 21:22
Ciao! :ciauz:
Vorrei sapere, siccome ho da poco aggiornato, la mia mdk dalla 10 alla 10.1, se possibile eliminare dalla cartella /boot quello che non serve, ovvero i kernel della vecchia versione con i suoi annessi e connessi...se no come si fa a fare "pulizia"?

Grazie ! :ciauz:

andy caps
17-02-2005, 21:44
:madai!?: io non lo farei nella dir /boot ci saranno 5 mb di file e rischi di non fare partire il sistema

pulisci /var/cache/urpmi/rpms dove probabilmente sono rimasti dei file gia installati

christian78
17-02-2005, 21:59
Ti ringrazio Andy per il suggerimento :zizi: ho provveduto a svuotare quella cartella, dove effettivamente c'era un p di roba, per c'erano solo rpm.

Io avevo fatto quella richiesta perch al momento del boot quando mi loggo con utente che non sia root, prima di riuscire ad accedere al sistema passano diversi minuti, e credevo che togliendo i vecchi kernel ecc, la cosa si potesse velocizzare....non possibile che per loggarmi ci metto anche 5 minuti abbondanti (poi una volta loggato il sistema funziona bene)...secondo te quale pu essere il problema?

andy caps
17-02-2005, 22:04
devi guardare dove si ferma al boot
in genere qualche servizio al boot che rallenta tutto

guarda con attenzione dai esc all boot e guarda cosa avviene

poi puoi disabilitare qualche servizio al boot da
mcc > sistema > servizi
diattivando la casella al boot

christian78
17-02-2005, 22:10
non il boot che lungo, ma la fase di login cio quando metto mio nomeUtente e password: quando gli do invio come se rimanesse a pensare (per un bel p) se farmi accedere o no, ma alla fine...dopo essermi preso un caff :stordita: avvia kde o gnome o la shell o cmq la sessione :bh:

andy caps
17-02-2005, 22:57
:master: allora un po piu complessa la cosa

dai un occhiata ai log in /var/log specie quelli di mdkkdm se vedi qualcosa di eccessivamente ricorrente

prova a fare un altro user e guarda se il login piu corto

prova anche il login da root

christian78
17-02-2005, 23:34
http://listafile.altervista.org/img/mdklog

questo il mio file mdkkdm.log : io non sono un esperto ma mi sa che vanno inconflitto xfree86 e xorg da quello che mi parso di capire...penso che cerchino di avviarsi entrambi (forse :confused: )


Ho 2 utenti normali sulla mia macchina e con entrambi c' il problema del login lungo.
Invece con utente root va tutto bene, si logga subito senza attese di nessun tipo

andy caps
18-02-2005, 00:00
no quello non c'entra
xorg non praticamente che lo sviluppo di xfree e quello il motivo dei messaggi

difficile capire cosa sia prova a partire dalla consolle riconfiguraando con mcc e disabiltando xfree al boot quando lo chiede per provare o disinstallando mdkkdm e gdm installa i -devel di xorg e prova comunque a creare un altro utente

sembra un problema di autorizzazioni se fa root non da problemi :confused:

christian78
18-02-2005, 09:09
Originariamente inviato da andy caps
difficile capire cosa sia prova a partire dalla consolle riconfiguraando con mcc e disabiltando xfree al boot quando lo chiede per provare o disinstallando mdkkdm e gdm installa i -devel di xorg e prova comunque a creare un altro utente

piano, piano.... :fagiano:
andiamo con ordine:
1) come faccio a partire dalla console se impostato per partire con un runlevel 5 (init 5) ?
2) con mcc da console cosa dovrei riconfigurare? solo le opzioni video? xfree non lo posso disinstallare?
3) mdkkdm cos'? a cosa serve?
4) adesso sono al lavoro...stasera quando torno a casa prover a creare un nuovo utente e ti far sapere


Scusa per le tante domande, ma vorrei capire bene e vorrei evitare di combinare casini :)
:ciauz:

andy caps
18-02-2005, 09:56
si se dai in un terminale di root il comando
init 3
esci da x e vai al consolle login
poi da root con mcc fai la configurazione video e scegli momentaneamente di non fare partire x al boot quando lo chiede espressamente
anche premendo ctrl + alt + F1 o f2 .... esci momentaneamente da x che rimane sempre attivo e premendo poi
ctrl+ alt + F7 ritorni

mdkkdm il pacchetto che mette il login grafico se non ne hai nessuno installato si ferma al login da consolle e poi xserver si avvia solo con startx

Loading