PDA

Visualizza la versione completa : apt "iceppato"


lion1810
19-02-2005, 16:30
Ciao raga ho un problemino con la knoppa.
Dopo aver installato xmame e gxmame ho visto che non riuscivo a vedere igiochi in fullscren . allora ho cercato se c'erano altri pacchetti:
xmame-x 0.86-3
xmame-svga 0.86-3
xmame-sdl 0.86-3
xmame-gl 0.86-3

ma quando cerco di installarli (ma mi succede per qualsiasi pacchetto):

root@box:/home/knoppix# apt-get install xmame-x
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
xmame-x gi alla versione pi recente.
consigliabile eseguire 'apt-get -f install' per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
xmame-x: Dipende: libxv1 ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare 'apt-get -f install' senza pacchetti (o specificare una soluzione).
root@box:/home/knoppix#


allora proviamo:


root@box:/home/knoppix# apt-get -f install Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
Correzione delle dipendenze in corso... Fatto
I seguenti pacchetti verranno inoltre installati:
libxv1
I seguenti pacchetti NUOVI (NEW) saranno installati:
libxv1
0 aggiornati, 1 installati, 0 da rimuovere e 883 non aggiornati.
7 non completamente installati o rimossi.
necessario prendere 0B/165kB di archivi.
Dopo l'estrazione, verranno occupati 332kB di spazio su disco.
Continuare? [S/n] s
(Lettura del database ... 104094 file e directory attualmente installati.)
Spacchettamento di libxv1 (da .../libxv1_4.3.0.dfsg.1-10_i386.deb) ...
dpkg: errore processando /var/cache/apt/archives/libxv1_4.3.0.dfsg.1-10_i386.deb (--unpack):
tentata sovrascrittura di `/usr/X11R6/lib/libXv.so.1.0', che si trova anche nel pacchetto xlibs
dpkg-deb: il sottoprocesso paste stato terminato dal segnale (Pipe rotta)
Sono occorsi degli errori processando:
/var/cache/apt/archives/libxv1_4.3.0.dfsg.1-10_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@box:/home/knoppix#

ho provato anche a cancellare maualmente il file libXv.so.1.0 con i suoi collegamenti. :cry: :cry:

Qualche suggerimento ??? :cry: :cry:

andy caps
19-02-2005, 16:40
:oVVoVe: mai cancellare le librerie
comprometti il sistema irrimediabilmente


devi dare un
dpkg --configure -a o in qyesto caso sarebbe bastato un
dpkg -i --force-all /var/cache/apt/archives/libxv1_4.3.0.dfsg.1-10_i386.deb

dai anche un apt-get update && apt-get dist-upgrade se hai l'adsl perche con 883 non aggiornati
il sistema non puo installare correttamente

lion1810
19-02-2005, 16:57
.. beh sinceramente l'ho solo spostato per poi rimetterle al suo posto

lion1810
19-02-2005, 17:01
:dh: ho solo il modem x l'adsl da dicembre che sto aspettando

lion1810
19-02-2005, 17:03
grazie ha ripreso a funzionare tutto correttamente :yuppi: :yuppi:

Loading