PDA

Visualizza la versione completa : MDK 10 modem ethernet non si connette


joker982
19-02-2005, 16:22
ho comprato un modem ethernet D-LINK 300T, all'inizio configurato in modo PPPoE, con linux riesco a connettermi tranquillamente

dal riavvio successivo non si connette più, ne in modalità PPPoE ne in modalità Bridge ( a cui sono passato dopo aver avuro problemi con win)
ho provato più volte a creare una nuova connesione, passo per passo uguale a quella che mi aveva permesso di connettermi la prima volta(procedura che vi elencherò qui sotto) ma nulla...

ricordo: MANDRAKE 10, modem D-Link 300T impostato da browser bridge

da centro di controllo mandrake:
reti internet -> nuova connesione -> connesione adsl -> seleziono la mia sche da di rete -> connesione PPPoE ->inserisco i miei dati (dsn primari e secondari..... ho provato sia a lasciare lo spazio bianco che successivamente a inserire 212.216.172.62 212.216.112.112)-> avvia al boot -> fine

la connesioni non va...riavvio...stessa cosa....

vado su monitoraggio connesioni sempre da pannello di controllo mdk -> seleziono connetti....nulla

vado su gestisci connesioni internet e imposto TCP/IP
come DHCP (prima era selezionato static)

ritorno sumonitoraggio connessioni e quando clicco su " connetti" qualcosa si muove...il grafico si anima... mi vengono trasmessi alcuni kb... e dopo un po' connesione completata....-> npn connesso

aiuti ?
grazie

andy caps
19-02-2005, 16:37
da consolle di root


adsl-setup


poi adsl-start per connettersi o adsl-connect

inverti i dns semmai

joker982
19-02-2005, 16:44
basta solo quello ?
la procedura che ho fatto è corretta ?
i dsn è meglio metterli o lasciare in bianco?

andy caps
19-02-2005, 16:53
si i dns sono fondamentali

drakconnect sinceramente da piu problemi che altro
la cosa migliore è configurarla durante l'installazione al riassunto delle configurazioni basta fare da li poi non ci rimetti mai le mani

guarda che sia installato rp-pppoe se non ti riconosce adsl-setup come comando

joker982
19-02-2005, 17:32
provato a fare...ma risultati negativi, mi spiego meglio

username inserisco im mio user sia con aliceposta.it, successivamente senza

interface eth0

demand value no, successivamente 60 secondi

DNS inserisco prima 212.216.172.62 212.216.112.112, poi viceversa

password psw

fine...mi riassume le mie impostazioni

adsl-start
apro il browser......nulla

adsl-status -> mi riporta il seguente messaggio
you have enabled demand connection
adsl-status may be inaccurate
adsl-status link is down (can't read pppoe pid file .pppoe)

non sapendo cos'è la demand connection e nemmeno il pppoe pid file
mi rivolgo a voi...

andy caps
19-02-2005, 17:41
:master: mi sembra che hai impiastricciato non poco la situazione

dai prima di tutto ifconfig e controlla la scheda

se ne hai due dai un dmesg | grep eth

per vedere chi è eth1 e eth0

poi con adsl-setup devi mettere

user >> nome@tin.it
domain niente
password
i dns entrambi
firewaall 0
se hai fatto qualche mezza connessione da mcc rimuovila e ripristina come in partenza

accertati che tutti i file siano installati
urpmi ppp rp-pppoe ppp-pppoe
poi prova con adsl-connect che dice qualcosa in piu

joker982
19-02-2005, 18:40
purtroppo nuovamente risultato negativo, riporto la mia esperienza:

dapprima cancello la connesione effettuata con il drakeconfig (centro di controllo mandrake),vado su rimuovi connesione, e rimuovo l'unica che avevo effettuato, mi da il messaggio eth(0) rimossa con successo

controllo i vari pacchetti urpmi ppp rp-pppoe ppp-pppoe
tutti già installati
da root do il comando ifconfig


Link encap:local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:62 errors 0 dropped:0 overruns:0 frame:0
TX packets:62 errors 0 dropped:0 overruns:0 carrier:0
collision:0 txqueuelen:0
RX bytes:3914 (3.8 Kb) RX bytes:3914 (3.8 Kb)

passo alla configurazione:


user name : miouser@aliceposta.it
activate-on-demand: No
primary dns : 212.216.172.62
secondary dns: 212.216.112.112
firewalling: NONE


adjusting /etc/ppp/pppoe.conf
adjusting /etc/resolv.conf
(but first backing it up to /etc/resolv.conf-bak)
adjusting /etc/ppp/pap-secrets and /etc/ppp/chap-secrets
(but first backing it up to /etc/ppp/pap-secrets-bak)
(but first backing it up to /etc/ppp/chap-secrets-bak)

faccio il solito adsl-start... la connesione non va

adsl-connect


/usr/sbin/adsl-connect: Chek '/etc//ppp/pppoe.conf' -- no setting for User

:dhò: :dhò:

Rommel
19-02-2005, 19:43
joker, io su gentoo non ho fatto tutti sti casini :)
non so se mandrake è diversa, però io ho fatto così:
ho configurato tutto da 192.168.1.1 , mettendo la modalità ppp-o-atm e mi basta dhcpcd per attivare la connessione.

i dns mettili in /etc/resolv.conf:

nameserver 193.70.192.25
nameserver 193.70.152.25

ovviamente modifica i dsn con quelli per la tua connessione :ciauz:

andy caps
19-02-2005, 19:53
adsl-connect lo devi dare da consolle di root non da user

poi dopo metti in mcc sistema > servizi adsl attivata al boot

con ifconfig non si vede la tua scheda di rete

se non compare eth0 o eth1 non andra' mai
è tutto li ifconfig ?

joker982
20-02-2005, 06:55
adsl-connect mi restituisce quel messaggio dando il comando da root

ora ifconfig mi rileva eth0, ma in quel modo non risolvo nulla

ora sono connesso da linux, ho impostato il modem PPPoA da browser, e dal pannello di controllo mandrake ho creato una nuova connesione adsl pppoa.

la strada da seguire è questa....anche se a me interessa connettermi con il modem in modalità bridge, in modo tale da non creare problemi nemmeno a win

Loading