PDA

Visualizza la versione completa : Internet: Xp vs il mio Linux


taylorella
24-02-2005, 02:37
Hola!
Ho un piccolo problemino, che sto cercando di risolvere da quasi una settimana.
Ho notato che Winz Xp di mio papà è più veloce del mio nella navigazione in internet, pur avendo lo stesso pc, e lo stesso Firefox (lui per winz e io per Linux).
L'unica differenza hardware è che io ho un modem V90 esterno, lui un V92 interno.
Ora vi chiedo: questa differenza di hardware è tale da giustificare un ritardo di apertura delle pagine usate come test (libero.it, microsoft.com/italy, altavista.com) che è arrivata a essere anche di 25 secondi sulla mia Mandrake 10.1?
Dopo un po'di consigli e ricerche, ho disattivato l'opzione ipv6 su Firefox, e ho disattivato la navigazione con dns locali su Kppp, e ammetto che navigo più veloce. Rimane il punto che sono comunque più lento di Xp.
In particolare i rallentamenti si hanno a causa dei tempi morti che intercorrono tra il momento in cui premo "invio" sulla barra degli indirizzi e il momento in cui in basso a destra compare la barra di caricamento. Mentre su Xp questo gap è di 1,5, massimo 3 secondi, da me arrivano a essere anche 6. Quindi navigo a una velocità effettiva dimezzata rispetto a Xp. Poichè reputo Mandrake una distribuzione valida(lo dicono anche le prove dell'ultimo numero di Linux Magazine), anche se un po' pesante dal punto di vista delle risorse, vorrei che mi aiutaste a capire perchè la connessione è così lenta rispetto a Xp, che come "pesantezza" è quantomeno paragonabile a Mandrake.
Conoscete qualche impostazione da modificare nel sistema, o proprio non posso farci nulla?
Ho dato un occhio anche a /etc/resolv.conf, ma credo di averlo reso innocuo deselezionando i dns locali su kppp. :bhò:
Penso di aver detto tutto: se ho dimenticato dei dettagli tecnici, ditemi cosa manca.
Faccio un piccolo resoconto delle differenze:

Pc veloce: Amd Athlon Xp2800+ con Windows Xp home SP2, modem interno pc-tel 56k con connessione diretta alla presa telefonica, Firefox 1.0

Pc lento: Amd Athlon Xp2800+ con Linux Mandrake 10.1 Official, modem esterno Trust communicator 56k esp-2 del'98 con collegamento alla linea filtrato da un ups Apc, Firefox 1.0.
Grazie e saluti alla community!
:ciauz:

discepolo
24-02-2005, 05:11
Originariamente inviato da taylorella
Mentre su Xp questo gap è di 1,5, massimo 3 secondi, da me arrivano a essere anche 6.

beh puoi fare altro in 6 secondi!!

:stordita:

Fabiuz
24-02-2005, 10:41
metti l'adsl sul tuo e vedrai che lo freghi.....



:maLOL: :maLOL: :maLOL: :maLOL: :maLOL: :maLOL: :maLOL:

Ilmalcom
24-02-2005, 10:42
Evitiamo di rispondere solo per aumentare il contapost, grasssssie :D

altor
24-02-2005, 13:10
Usate esattamente gli stessi dns??

Dico questo perchè il tempo che passa fra il tasto invio e la comparsa della barra di caricamento è condizionato dalla velocità di risoluzione dell'indirizzo.

Ci sono passato qualche tempo fa (se volevo andare piu' veloce dovevo modificare i dns negoziati dal router con quelli del provider, poi la cosa si è aggiustata..)

Ciao!

taylorella
24-02-2005, 16:38
Ottima domanda: come ho scritto, dalle ricerche che ho fatto ho scoperto che i dns rivestono un ruolo fondamentale sui tempi morti, per questo ho disattivato i dns locali (che tra l'altro non so cosa siano! :confused: ), però non so come fare per vedere se usiamo gli stessi dns, e se no, come modificarli. Sapete cosa e come devo fare?
P.S: sono entrambe soluzioni che avevo considerato, ma x l'adsl ne abbiamo già uno, ed è di stretta proprietà paterna, mentre nei sei secondi in cui potrei fare dell'altro, in realtà non posso fare dell'altro, perchè andrei solo a sovraccaricare una connessione già di per sè non ottimale. A meno che per altro non intendi compilare un sorgente, manipolare una foto, mangiarmi un panino...! :zizi:

altor
24-02-2005, 18:22
Originariamente inviato da taylorella
Ottima domanda: come ho scritto, dalle ricerche che ho fatto ho scoperto che i dns rivestono un ruolo fondamentale sui tempi morti, per questo ho disattivato i dns locali (che tra l'altro non so cosa siano! :confused: ), però non so come fare per vedere se usiamo gli stessi dns, e se no, come modificarli. Sapete cosa e come devo fare?


Intanto guarda cosa hai nel file resolv.conf (magari posta il contenuto).

Ciao!

taylorella
25-02-2005, 00:41
Ho trovato il file che mi hai detto:si trova dentro etc/ppp/ e c'era scritto:
nameserver 193.70.152.15
nameserver 193.70.152.25

Poi ho trovato un altro resolv.conf, questa volta all'interno di /etc/ ma non di etc/ppp/, insomma era in mezzo agli altri file di etc, e c'era scritto:
nameserver 127.0.0.1
nameserver 192.168.0.2

In definitiva ho 2 file resolv.conf, e all'interno c'era sta roba qua. Io navigo con Libero 56k con il 7021055000, quindi senza acceleratori 6x o boiate del genere. Fammi sapere...
Intanto grazie per l'interessamento!
:)

Caleb
25-02-2005, 00:55
commenta (o cancellale) con un # le righe in /etc/resolv.conf, non ti servono a nulla

/etc/ppp/resolv.conf viene aggiornato al volo quando stabilisci una connessione, ma /etc/resolv.conf viene letto comunque ad ogni risoluzione

taylorella
25-02-2005, 01:36
Intanto ti faccio i complimenti per la tua firma: troppo gagliarda!!! :unz: Ma dove l'hai pescata?!?
Non vorrei aver capito male: è sufficiente mettere un cancelletto davanti a "nameserver"? Tutto qui?!? :oVVoVe:
Perchè io ho già disattivato i dns locali con un'opzione di kppp, e non vorrei mai fare cazzate sul sistema, visto che modificare i file di configurazione è sempre un affare delicato...
Adesso provo a mettere sto cancelletto all'inizio delle righe...
Ah già: va messo all'inizio di ogni riga, non solo della prima, vero?
Intanto grazie: chissà che riesca a rendere Linux alla pari di Windows (ovviamente non nel senso che lo peggioro! :maLOL: )

Loading