PDA

Visualizza la versione completa : [annuncio] gSmile 0.1.0


vortex87
24-02-2005, 22:05
Salve a tutti :fighet:
(finalmente posso scrivere un annuncio in italiano :zizi: )

[traduttore mode]
Sono cos... felice di annunciare la... prima release pubblica... di gSmile:
[/traduttore_mode]

Cos' :oVVoVe:? vi chiederete :stordita:
Ebbene, sappiate che gSmile quello che avete sempre desiderato.
gSmile La Cosa. http://forum.html.it/forum/faccine/098.gif
Ma a parte questo, gSmile anche un emoticon manager (o gestore di faccine :incupito: ) open-source, scritto in Python che sfrutta le gtk tramite pygtk
Provatelo e non ve ne pentirete http://forum.html.it/forum/faccine/098.gif (questo smiley, ad esempio, lo ho inserito con gSmile: non nelle faccine qui a fianco, ma io lo ho archiviato nel programma e mi bastato trascinarlo sulla textarea della pagina per avere il suo url inserito tra il tag :unz:

http://gsmile.sourceforge.net/

[img]http://gsmile.sourceforge.net/uploads/images/einstein_r.jpg

Qui c' il testo dell'annuncio originale :stordita:



Hi everybody

I'm so glad to announce the first public release of gSmile: gSmile 0.1.0

*gSmile* is an open-source emoticon manager, that is a nice piece of software that helps you to keep your emoticons and smilies organized and to find them quickly whenever you need one of them.
It supports emoticon storing in nested folders with drag'n'drop from and towards the web-browser.


gSmile is written in Python and uses this great wrapper, PyGTK, for the GTK+ toolkit.
You can find all the information you need, the support forum, the mailing-list and some shots, too, on gSmile home page at http://gsmile.sourceforge.net/


This release is still an alpha development release: this because there aren't yet all the features I want for the first stable release, but gSmile now has enough features to be considered useful.

Currently these features are present:
- Folder create/delete/edit/move up/down
- Emoticon storage (with drag'n'drop from the browser)
- Emoticon usage (with drag'n'drop to the browser)
- Window-behaviour preferences
- Multiple tag-mode functionality (4 predefined, or write your own - no saving of custom ones)


These are the tarballs:

Source package: untar it and run `python setup.py install'

gsmile-0.1.0.tar.gz md5sum: 56454ec7d5621dd29c4d514fe3b1ab0e
http://prdownloads.sourceforge.net/gsmile/gsmile-0.1.0.tar.gz?download

Binary package: untar it under / (the root directory), files will be placed in the right place

gsmile-0.1.0.linux-i686.tar.gz md5sum: 63cb988b988e1af5526b62780a063ac0
http://prdownloads.sourceforge.net/gsmile/gsmile-0.1.0.linux-i686.tar.gz?download


Give it a try and report any bug you find, please.


Thanks very much, Federico Pelloni

Guglie
24-02-2005, 22:16
ciao vortex :)

l'idea non affatto malvagia:
domani o dopo faccio un po' di testing e ti faccio sapere

:ciauz:

vortex87
24-02-2005, 22:20
Ciao e grazie :D

Pi che un'idea infatti una necessit: l'unico programma di questo genere che ho trovato uno shareware che funziona solo su sistemi operativi nordamericani (come ho scritto sul sito) :incupito: (emotipad si chiama, se interessa...)


Testing :sbav:

E' proprio quello di cui ho bisogno :fighet: (anche tenendo conto che il mio primo progetto in python)

lnessuno
24-02-2005, 22:43
preso, scaricato la versione binaria...


bruttissimo che tenti di installarsi in /usr... :nonono:

non si potrebbe farne una versione che si installa dove vuoi, e lo lanci da li? :sbav:

maiosyet_2
24-02-2005, 22:49
Complimenti :zizi: giusto un piiiccolo problema :fagiano:

Il giocattolo necessita di pygtk <= 2.5.0 ma il portage (ho appena syncato per esserne sicuro) neppure ce l'ha, fermo alla 2.4.1 del 22 dic 2004 :master:

Quindi o sistemi le dipendenze o ciccia :stordita:

Ah, a porposito: c' un modo per disinstallarlo? (visto che per ora non lo posso usare)

vortex87
24-02-2005, 22:51
Perch non dovrebbe installarsi in /usr? :master: Tutti i programmi python vanno a finire l :stordita:

Comunque se si prende la versione sorgente (alla fine c' solo la libreria per la trayicon da compilare, ci vuole solo qualche secondo) la si pu installare dove si vuole: "./setup.py install --prefix=/home/utente/test" :fighet:

Ho anche fatto un bel po' di prove, dovrebbe funzionare in qualsiasi posizione lo si installi :stordita:

vortex87
24-02-2005, 22:54
Originariamente inviato da maiosyet_2
Complimenti :zizi: giusto un piiiccolo problema :fagiano:

Il giocattolo necessita di pygtk <= 2.5.0 ma il portage (ho appena syncato per esserne sicuro) neppure ce l'ha, fermo alla 2.4.1 del 22 dic 2004 :master:

Quindi o sistemi le dipendenze o ciccia :stordita:

Ah, a porposito: c' un modo per disinstallarlo? (visto che per ora non lo posso usare)

Grazie :zizi:

Il problema che il giocattolino necessita delle GTK 2.6 per l'IconList (il widget dove appaiono le emoticons), che sono supportate solo dalla versione development di PyGTK (www.pygtk.org) :stordita: Comunque a breve dovrebbe uscire la versione stabile (2.6)

Per quanto riguarda la disinstallazione: boh? :fagiano: su slack io creo il pacchetto con


checkinstall './setup.py install'

che dovrebbe funzionare anche su debian e rpm-based

Per gent non so :bh:

lnessuno
24-02-2005, 22:55
Originariamente inviato da vortex87
Perch non dovrebbe installarsi in /usr? :master: Tutti i programmi python vanno a finire l :stordita:

Comunque se si prende la versione sorgente (alla fine c' solo la libreria per la trayicon da compilare, ci vuole solo qualche secondo) la si pu installare dove si vuole: "./setup.py install --prefix=/home/utente/test" :fighet:

Ho anche fatto un bel po' di prove, dovrebbe funzionare in qualsiasi posizione lo si installi :stordita:


mmm non si pu fare un pacchetto che uno si installa dove preferisce? secondo me pi comodo... cos se uno volesse spostarlo lo fa senza problemi, e ha solo una dir da maneggiare... :)

anche io cmq ho avuto problemi con la versione di pygtk... :(

vortex87
24-02-2005, 23:01
Dalla versione sorgenti, se invece di './setup.py install' si d './setup.py build' dovrebbe compilare l'estensione per la trayicon e poi funzionare direttamente dalla directory dei sorgenti con ./gsmile

Non garantisco :stordita:

Guglie
24-02-2005, 23:06
Originariamente inviato da maiosyet_2
Complimenti :zizi: giusto un piiiccolo problema :fagiano:

Il giocattolo necessita di pygtk <= 2.5.0 ma il portage (ho appena syncato per esserne sicuro) neppure ce l'ha, fermo alla 2.4.1 del 22 dic 2004 :master:

Quindi o sistemi le dipendenze o ciccia :stordita:

inoltre per ora in gentoo anche le ultime gtk+ marcate stabili sono le 2.4.14, per ora le 2.6.* sono ancora in testing
credo che hai scelto di usare delle feautures un po' troppo precoci, cmq sicuramente fra qualche tempo quei programmi diventeranno stabili e non ci saranno pi problemi :)

per ora per dovrei compilarmi pygtk a mano per provarlo :cry:

Loading