PDA

Visualizza la versione completa : [lm-sensors] ma cosa cavolo devo caricare?


gianiaz
25-02-2005, 14:32
Ciao, ho appena terminato l'installazione di una debian con un cd di net-install partendo da un kernel 2.6.8.1, ho installato lm-sensors con apt-get, e ho lanciato


gianiaz:# sensors-detect
We can start with probing for (PCI) I2C or SMBus adapters.
You do not need any special privileges for this.
Do you want to probe now? (YES/no):
Probing for PCI bus adapters...
Use driver `i2c-i801' for device 00:1f.3: Intel 82801DB ICH4
Probe succesfully concluded.

We will now try to load each adapter module in turn.
Module `i2c-i801' already loaded.
If you have undetectable or unsupported adapters, you can have them
scanned by manually loading the modules before running this script.

To continue, we need module `i2c-dev' to be loaded.
If it is built-in into your kernel, you can safely skip this.
i2c-dev is already loaded.

We are now going to do the adapter probings. Some adapters may hang halfway
through; we can't really help that. Also, some chips will be double detected;
we choose the one with the highest confidence value in that case.
If you found that the adapter hung after probing a certain address, you can
specify that address to remain unprobed. That often
includes address 0x69 (clock chip).
¨
Next adapter: SMBus I801 adapter at dc80
Do you want to scan it? (YES/no/selectively):
Client found at address 0x08
Client found at address 0x44
Probing for `Maxim MAX6633/MAX6634/MAX6635'... Failed!
Client found at address 0x50
Probing for `SPD EEPROM'... Success!
(confidence 8, driver `eeprom')
Probing for `DDC monitor'... Failed!
Probing for `Maxim MAX6900'... Failed!
Client found at address 0x61
Probing for `SMBus 2.0 ARP-Capable Device'... Success!
(confidence 1, driver `smbus-arp')
Client found at address 0x64
Client found at address 0x69

Do you want to scan the ISA bus? (YES/no):
Probing for `National Semiconductor LM78'
Trying address 0x0290... Failed!
Probing for `National Semiconductor LM78-J'
Trying address 0x0290... Failed!
Probing for `National Semiconductor LM79'
Trying address 0x0290... Failed!
Probing for `Winbond W83781D'
Trying address 0x0290... Failed!
Probing for `Winbond W83782D'
Trying address 0x0290... Failed!
Probing for `Winbond W83627HF'
Trying address 0x0290... Failed!
Probing for `Winbond W83697HF'
Trying address 0x0290... Failed!
Probing for `Silicon Integrated Systems SIS5595'
Trying general detect... Failed!
Probing for `VIA Technologies VT82C686 Integrated Sensors'
Trying general detect... Failed!
Probing for `VIA Technologies VT8231 Integrated Sensors'
Trying general detect... Failed!
Probing for `ITE IT8705F / IT8712F / SiS 950'
Trying address 0x0290... Failed!
Probing for `IPMI BMC KCS'
Trying address 0x0ca0... Failed!
Probing for `IPMI BMC SMIC'
Trying address 0x0ca8... Failed!


Do you want to scan for Super I/O sensors? (YES/no):

Probing for `ITE 8702F Super IO Sensors'
Failed! (0x6701)
Probing for `ITE 8705F Super IO Sensors'
Failed! (0x6701)
Probing for `ITE 8712F Super IO Sensors'
Failed! (0x6701)
Probing for `Nat. Semi. PC87351 Super IO Fan Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87360 Super IO Fan Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87363 Super IO Fan Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87364 Super IO Fan Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87365 Super IO Fan Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87365 Super IO Voltage Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87365 Super IO Thermal Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87366 Super IO Fan Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87366 Super IO Voltage Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87366 Super IO Thermal Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87372 Super IO Fan Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC87373 Super IO Fan Sensors'
Failed! (0x67)
Probing for `Nat. Semi. PC8739x Super IO'
Failed! (0x67)
Probing for `Nat. Semi. PC8741x Super IO'
Failed! (0x67)
Probing for `SMSC 47B27x Super IO Fan Sensors'
Failed! (0x67)
Probing for `SMSC 47M10x/13x Super IO Fan Sensors'
Failed! (0x67)
Probing for `SMSC 47M14x Super IO Fan Sensors'
Failed! (0x67)
Probing for `SMSC 47M15x/192 Super IO Fan Sensors'
Failed! (0x67)
Probing for `SMSC 47S42x Super IO Fan Sensors'
Failed! (0x67)
Probing for `SMSC 47S45x Super IO Fan Sensors'
Failed! (0x67)
Probing for `SMSC 47M172 Super IO'
Failed! (0x67)
Probing for `SMSC LPC47B397-NC Super IO'
Failed! (0x67)
Probing for `VT1211 Super IO Sensors'
Failed! (skipping family)

To make the sensors modules behave correctly, add these lines to
/etc/modules:

#----cut here----
# I2C adapter drivers
i2c-i801
# I2C chip drivers
eeprom
smbus-arp
#----cut here----


Ok, a parte tutto l'output, credo che comunque non abbia trovato i moduli che a me servono...



gianiaz:# lspci
0000:00:00.0 Host bridge: Intel Corp. 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 01)
0000:00:02.0 VGA compatible controller: Intel Corp. 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCI Controller (rev 01)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 81)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DB/DBL (ICH4/ICH4-L) LPC Bridge (rev 01)
0000:00:1f.1 IDE interface: Intel Corp. 82801DB/DBL (ICH4/ICH4-L) UltraATA-100 IDE Controller (rev 01)
0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
0000:01:0c.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 10)
gianiaz:/dev/i2o#


i moduli giÓ compilati in mio possesso sono questi:



ianiaz:/dev/i2o# ls -R /lib/modules/2.6.8-1-386/kernel/drivers/i2c/
/lib/modules/2.6.8-1-386/kernel/drivers/i2c/:
algos busses chips i2c-core.ko i2c-dev.ko i2c-sensor.ko

/lib/modules/2.6.8-1-386/kernel/drivers/i2c/algos:
i2c-algo-bit.ko i2c-algo-pcf.ko

/lib/modules/2.6.8-1-386/kernel/drivers/i2c/busses:
i2c-ali1535.ko i2c-amd756.ko i2c-i801.ko i2c-nforce2.ko i2c-piix4.ko i2c-sis5595.ko i2c-via.ko scx200_acb.ko
i2c-ali1563.ko i2c-amd8111.ko i2c-i810.ko i2c-parport.ko i2c-prosavage.ko i2c-sis630.ko i2c-viapro.ko scx200_i2c.ko
i2c-ali15x3.ko i2c-elektor.ko i2c-isa.ko i2c-parport-light.ko i2c-savage4.ko i2c-sis96x.ko i2c-voodoo3.ko

/lib/modules/2.6.8-1-386/kernel/drivers/i2c/chips:
adm1021.ko adm1031.ko ds1621.ko fscher.ko it87.ko lm77.ko lm80.ko lm85.ko max1619.ko pcf8591.ko via686a.ko w83781d.ko
adm1025.ko asb100.ko eeprom.ko gl518sm.ko lm75.ko lm78.ko lm83.ko lm90.ko pcf8574.ko rtc8564.ko w83627hf.ko w83l785ts.ko



Quale devo caricare?
I dev vengono creati in auto? perchŔ io in /dev/ non ho niente riguardante i2c.

Grazie, ciao

fra7576
25-02-2005, 14:51
questi ??

#----cut here----
# I2C adapter drivers
i2c-i801
# I2C chip drivers
eeprom
smbus-arp
#----cut here----


cmq qui Ŕ esposta molto chiaramente la config del kernel:
http://www2.lm-sensors.nu/~lm78/kernel26.html

Loading