PDA

Visualizza la versione completa : usare hd grandi


smt
25-02-2005, 18:41
ho installato un HD western digital da 250 gb, linux(debian kernel 2.20.20) ne rileva solo 131. Ho aggiornato il kernel alla 2.4.18, avendo trovato in rete che occorre il supporto per ata-6 per leggere dischi > 137 Gb e che la 2.20 non li supporta mentre li supporta la 2.4, ma senza successo.

qualcuno sa darmi una qualche idea?

andy caps
25-02-2005, 20:16
se installi un kernel recente non ha problemi
:bh: io per sistemare il disco installo prima mandrake (he non ha problemi a vederlo) poi se voglio installare la woody la installo in una delle partizioni al di sotto dei 138gb
poi naturalmente con gli ultimi kernel anche debian vede tutto il disco

conviene fare cosi perche creando una partizione estesa che va fino a 138gb poi il rimanente sei costretto a dividerlo in partizioni primarie ( 4 al massimo )

mykol
25-02-2005, 21:20
Io con MDK 10.1 official kernel 2.6.8.1-12mdk, con un HD Maxtor da 160 GB ho:

[root@MDK10 giorgio]# fdisk -l

Disk /dev/hda: 163.9 GB, 163928604672 bytes
255 heads, 63 sectors/track, 19929 cylinders
Units = cilindri of 16065 * 512 = 8225280 bytes

Dispositivo Boot Start End Blocks Id System
/dev/hda1 * 1 10658 85610353+ 83 Linux
/dev/hda2 10659 19929 74469307+ 5 Esteso
/dev/hda5 10659 11365 5678946 82 Linux swap
/dev/hda6 11366 12772 11301696 83 Linux
/dev/hda7 12773 14169 11221371 83 Linux
/dev/hda8 14170 15554 11124981 83 Linux
/dev/hda9 15555 16939 11124981 83 Linux
/dev/hda10 16940 17651 5719108+ 83 Linux
/dev/hda11 17652 18389 5927953+ 83 Linux
/dev/hda12 18390 19133 5976148+ 83 Linux
/dev/hda13 19134 19929 6393838+ 83 Linux
[root@MDK10 giorgio]#

credo di avere una partizione primaria da circa 80 GB (MDK 10.1) ed una partizione secondaria contenete 8 partizioni logiche ? da 10 e 5 GB ...

Linux2004
25-02-2005, 21:20
Ma pu dipendere anche dal bios? Giusto?

mykol
25-02-2005, 21:33
credo di si.

io non riuscivo a pertizionarlo, mi dava un sacco di problemi (ci ho anche rimesso circa 10 GB) e poi era dovuto al fatto che quando l'ho montato ho staccato un altro HD che avevo sullo stesso controller e quindi collegato come slave sullo stesso cavo, ma ho scollegato solo il cavo di alimentazione, dimenticandomi di scollegare anche il cavo dati ...

Loading