PDA

Visualizza la versione completa : [gentoo] Problema con apache2


Rommel
10-03-2005, 17:47
ciao a tutti,
dopo alcuni errori ho installato apache2 su gentoo.

il sito (non è spamming, non c'è nulla. dovrebbe vedersi una pagina index.html con scritto index) è www.occasus.zapto.org .

come vedete c'è un login, ma non riesco a loggarmi né come utente root, né con i dati di no-ip.

da locale ( http://127.0.0.1 , http://localhost , http://occasus ) non ho problemi.

che posso fare?

hope for us
10-03-2005, 17:57
Cioè in pratica ti chiede 1 autenticazione se dai l'indirizzo
http://www.occasus.zapto.org/, mentre in locale ti mostra la pagina senza problemi? Come hai impostato l'httpd.conf?

Rommel
10-03-2005, 18:17
esatto.

non capisco se è un errore riguardante no-ip e il suo client o se è apache.

http://rommel.altervista.org/httpd.txt

hope for us
10-03-2005, 18:33
Premetto che sono abbastanza neofita di apache ,cmq se è vero che no-ip ha che fare con il DNS, allora non penso sia quella la causa visto che il sito viene raggiunto normalmente. Piuttosto penso sia 1 problema di virtualhost e come c'è scritto in fondo al tuo httpd in Gentoo i virtualhost vengono trattati in 1 file a parte. Penso che sia 1 problema di directory del virtualhost a cui può essere stata imposta 1 direttiva di Allowoverride Authconfig relativamente a quel virtualhost (potevo usarla più volte quella parola già che c'ero... :-) ). Cmq la mia conoscenza di apache è tale che potrei aver averti detto una solenne cavolata. Se qcuno ne sa di + mi smentisca al volo che così imparo 1 pò anch'io...

osiryx
10-03-2005, 18:38
Nn è che hai un file .htaccess in quella dir ?

Rommel
10-03-2005, 18:49
@hope for us: boh, da ciò che ho capito non mi pare che sia così

@osiryx: non ci sono .htaccess

poi la cosa strana dell'errore è che dice access denied a /doc/index.htm

ma...il file vero si trova in:
~/Desktop/www/index.html :master:

hope for us
10-03-2005, 20:40
Scusa 1 cosa, ma in questo httpd.conf non è definito l'host a cui ti vuoi collegare (http://www.occasus.zapto.org/), quindi dovresti averlo definito da 1 altra parte. il discorso è: dov'è definito?
X quanto riguarda il discorso /doc/ invece di ~/Desktop/www/ciò può essere facilmente ottenuto all'interno della sezione virtualhost che secondo me si trova in un altro .conf
Cmq le mie sono solo congetture... :rollo:

Rommel
10-03-2005, 20:58
praticamente io ho installato con portage apache2, php, mysql e ssl ed in locale sembra funzionare tutto.

poi ho installato il client di no-ip, l'ho configurato ed il risultato è l'orrore che si vede entrando in www.occasus.zapto.org .

per quanto riguarda gli altri conf, non credo sia quello il problema perché da locale vedo bene le pagine.

il conf è in /etc/apache2/httpd.conf

vedi/vedete qui:
www.occasus.zapto.org/index.php

che c'entrano gli rpm con gli ebuild di gentoo? :dottò: :(

a questo punto dovrebbe trattarsi di un errore legato al client no-ip o a no-ip stesso :master:
ma quale?

hope for us
10-03-2005, 21:16
Ultima cosa e poi smetto che non ti sono molto d'aiuto. Di solito in servername non si mette qcosa tipo www.pippo.it? Tu hai messo solo occasus e non so se ciò è sufficiente. ad esempio tu raggiungi la pagina con 127.0.0.1 e localhost che dovrebbero essere nel tuo /etc/hosts e con occasus che è il servername. Prova a dargli come servername www.occasus.it (non mi ricordo se il www serve...). Poi smetto di portarti fuori strada, promesso...

:)

hope for us
10-03-2005, 21:23
Ora si vede,anche se non penso il merito sia mio...
:D

Loading