PDA

Visualizza la versione completa : PPP e il supporto ppp_generic


ZoneForum
11-03-2005, 19:38
Quando cerco di connettermi mi restituisce il seguente errore:

Plugin /usr/lib/pppd/plugins/pppoatm.so loaded. Kernel doesn't support ppp_generic - needed for PPPoATM

Che vuol dire che devo ricompilare il kernel :prrr:

Mi dite, prima che inizi, quale opzione in particolare devo attivare per far sì che non mi restituisca quel messaggio (magari qualcosa nel menu... mica troverò "ppp_generic"?)?


Grazie


:ciauz:

andy caps
11-03-2005, 19:43
prima magari prova a caricare ppp-deflate

<M> PPP (point-to-point protocol) support

questo mette ppp_generic

ZoneForum
11-03-2005, 19:46
Ok, grazie...
Ma mi sembrava di averlo attivato...


Boh :master:

ZoneForum
12-03-2005, 16:20
Ho controllato nel .config e ho:
CONFIG_PPP_DEFLATE=m
Intendevi questo?
Se sì, ce l'ho attivato ma mi dà quell'errore...
Che devo fare?


Grazie


:ciau:

ZoneForum
12-03-2005, 20:56
Up

kernel 2.6.7 - slack 9.1

ZoneForum
12-03-2005, 22:12
Ho provato a ricompilarlo abilitando il modulo "<M> PPP (point-to-point protocol) support" ma mi dà sempre lo stesso errore! :dhò:
Anche prima era così (infatti ero sicuro di aver compilato giusto, anche perchè il .config non mente :nonono:)...
Non è che bisogna installare qualcos'altro?

Che faccio? :stordita:


:cry:



:ciauz:

ZoneForum
13-03-2005, 10:51
Una volta che il mio modem (Fastrate 100 USB) è andato in SHOWTIME_LO, eseguo questo comando:
:pppd file /etc/ppp/options-atm
E lui mi restituisce:
>Plugin /usr/lib/pppd/plugins/pppoatm.so loaded.
>Kernel doesn't support ppp_generic - needed for PPPoATM
Allora eseguo (con successo):
:modprobe ppp-generic
E quando riprovo ad eseguire:
:pppd file /etc/ppp/options-atm
Lui mi restituisce:
>Plugin /usr/lib/pppd/plugins/pppoatm.so loaded.
>PPPoATM plugin_initialized
>PPPoATM setdevname_pppoatm - SUCCESS
>No QOS string in open_device_pppoatm()
>Plugin pppoatm.so loaded.
>PPPoATM plugin_initialized
>PPPoATM setdevname_pppoatm - SUCCESS
Ma quando provo ad eseguire:
:ping yahoo.com
Lui mi restituisce che non trova l'host, ergo non è connesso...

Che ho sbagliato?


P.S.: quando eseguo "modprobe ppp_deflate" lui mi restituisce:

WARNING: Error inserting zlib_deflate (/lib/modules/2.6.7/kernel/lib/zlib_deflate/zlib_deflate.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting ppp_deflate (/lib/modules/2.6.7/kernel/drivers/net/ppp_deflate.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Quindi vado a vedere in "dmesg" e trovo:

zlib_deflate: Unknown symbol cleanup_module
ppp_deflate: Unknown symbol zlib_deflateInit2_
ppp_deflate: Unknown symbol zlib_deflateEnd
ppp_deflate: Unknown symbol zlib_deflate
ppp_deflate: Unknown symbol zlib_deflateReset
ppp_deflate: Unknown symbol zlib_deflate_workspacesize

:cry: :cry: :cry:


Grazie


:ciauz:

andy caps
13-03-2005, 11:09
hai messo i dns in /etc/resolv.conf ??

quell'errore di ppp_deflate non l'ho mai visto
sembra che manchi qualche dipendenza
prova a ricompilare abilitando delle opzioni in piu nel gruppo net

guarda di avere messo anche dal gruppo charatter

nbd
loopback

ZoneForum
13-03-2005, 11:27
Originariamente inviato da andy caps
hai messo i dns in /etc/resolv.conf ??

quell'errore di ppp_deflate non l'ho mai visto
sembra che manchi qualche dipendenza
prova a ricompilare abilitando delle opzioni in piu nel gruppo net

guarda di avere messo anche dal gruppo charatter

nbd
loopback

I DNS li ho messi... Più che altro non so se sono quelli giusti...


Comunque dici che devo abilitare qualcosa in più nell'opzione "NETWORK" (in pratica quella in cui si trovano le opzioni di PPP?)?


L'ultimo pezzo non l'ho capito :fagiano:

andy caps
13-03-2005, 11:42
nella sezione charatter del kernel guarda di avere abilitto quelle opzioni

non so che provider usi
per alice ad esempio

212.216.112.112
212.216.172.62

in ppp aggiungi un po di opzioni tralasciando il filtering

Loading