PDA

Visualizza la versione completa : Abilitazione 3d


Ghost22
12-03-2005, 13:10
Pultroppo ho cercato un po in rete e sul forum ma non ho trovato niente che riuscisse ad aiutarmi
Ho una redeon 9700 su una mdk10.1
Quando avevo la 10.0 bastava che installavo il pacchetto ati_kernel e tutto mi funzionava senza che dovessi muovere un dito, ma adesso un po diverso. Per quanto io installi il modulo della ati presente stesso nel dvd di installazione della mdk la sckeda continua a abilitare l'accelerazione 3d.
Ho notato che a molti nel lsmod non usciva la voce fglrx ma a me c' :-(

fglrx 226684 7
installato ancke il modulo agp

via-agp 7360 1
agpgart 27752 2 via-agp
che in un altro topic avevo visto essere necessario... ditemi voi cosa devo fare, seza dovre compilare la magior parte del sistema :-((((

Caleb
12-03-2005, 13:23
gia' provato a installare i driver dal sito ati con rpm -i driver.rpm --force?

Ghost22
12-03-2005, 13:44
Ok fatto come dici te, solo che adesso kde non mi riparte all'avvio, quindi ho dovuto togliere il driver e rimettere quello del Dvd.
Adesso noto che all'inizio quando avvio linux mi da errore nel caricamento del modulo ati (error 4) o una cosa simile e se provo a far partire qualcosa che implica il 3d (es uno screensaver opengl) mi si riavvia il sever grafico.... mo sto messo peggio di prima :-((((((

Caleb
12-03-2005, 14:25
purtroppo i driver ati sono una porcheria, tocca adattarsi

rpm -i driver.rpm --force per installarli, fglrxconfig per configurare il tutto

Ghost22
12-03-2005, 15:18
ok fatto configurato ma non funziona lo stesso il d, inoltre la risuluzione mi scesa a 640x480, ho provato a riconfigurare con una risoluzione + alta ma poi mi da errore del sever grafico e non mi parte + niente. Ho cancellato il pacchetto ed installato di nuovo il modulo ati, ma stavolta da console e ho visto che installando il paccheto ati-kernel
mi da il seguente errore
Error: Could not locate fglrx.ko.gz ati in DKMS tree. You must run a dkms build for kernel 2.6.8.1-12mdk (i686) first.
ati 3.14.1 2.6.8.1-12 i686:build (worry! Missing some biuld modules)

Adesso prmettendo che non so come si usa il DKMS l'ho installato sempre da console e per soddifare le dipendenze mi ha fatto installare ancke i sorgenti del kernel.. a sto punto se devo compilare ditemi come devo fa.

Caleb
12-03-2005, 15:47
il dkms l'albero dei moduli, non propriamente un programma da utilizzare

i sorgenti dei kernel non dovrebbero pi essere necessari con gli ultimi driver (almeno a quanto si dice sul sito ati), hai scaricato gli ultimi disponibili?

Ghost22
12-03-2005, 16:51
si si

Caleb
12-03-2005, 17:13
ora che gli hai messo a disposizione i sorgenti del kernel, se rifai l'installazione dei driver dovrebbe andare

guarda con uname -r la versione del kernel che stai usando, quelli in usr/src/linux devono essere gli stessi

Ghost22
12-03-2005, 20:28
2.6.8.1-12mdk

datto un dir in /usr/src

[root@localhost src]# dir
ATI ati-3.14.1 linux linux-2.6.11-2mdk RPM

dir dentro linux
[root@localhost linux]# dir
3rdparty CREDITS drivers init kernel Makefile README scripts usr
arch crypto fs ipc lib mm REPORTING-BUGS security
COPYING Documentation include kdb MAINTAINERS net rsbac sound

adesso che devo fare?

Caleb
12-03-2005, 20:59
c'e' un intoppo

se la versione attuale del kernel corrispondesse a quella dei sorgenti ti basterebbe reinstallare i driver con rpm e ridare flgrxconfig, ma tu stai usando la 2.6.8.1 e i sorgenti ce li hai per la 2.6.11

puoi provare ugualmente, al massimo si inchioda di nuovo... la situazione ideale sarebbe compilare e installare il kernel 2.6.11 o, alla peggio, scaricare i sorgenti del 2.6.8.1 da kernel.org e sostituirli a quelli nuovi

Loading