PDA

Visualizza la versione completa : scheda audio integrata via82cx


kentaromiura
14-03-2005, 09:57
:D
ho dato un occhiata in giro e sta scheda da un mucchio di problemi..
allora :
ho un pc con la suddetta scheda audio, su fedora 2/3 funziona sulle altre distro no.
penso , sarà un problema di Kernel?
macche' ricompilo con le stesse opzioni il kernel su fedora e su qls altra distro e funziona ancora solo su fedora
dico allora sara' un problema di moduli del kernel
faccio un bel modprobe --remove snd-via82xx
e un modinfo snd-via82xx e riprovo con tutte le combinazioni alzando ognivolta il volume al massimo ma niente..
il bello e' che alsaconf la riconosce e la setta
ma continua ad andare solo su fedora..
copio il file modules.conf (o come si chiamava..comunque quello giusto) da fedora a distro X e continua a non andare..
provato su :

fedora 2 /3
slackware 10.1
arch linux
ubuntu 4.xx e 5.xx

magie di Fedora?

matteoma
14-03-2005, 10:39
Ciao

Anch'io ho quella maledetta scheda sonora in un Sony Vaio pcg fr2145e che fa impazzire.
Con Slack (visto che mi pare usi) ho risolto disattivando l' hotplug e attivando manualmente il relativo modulo OSS in rc.modules. Funziona anche con il kernel 2.6...

Confermo anch'io che con altre distro tipo Ubuntu e simili non sono mai riuscito a farla funzionare. Ma ti dico anche che non ho la capacità di ricompilare il Kernel e fare altre operazioni complesse.

Ciao

andy caps
14-03-2005, 15:06
:master: a me non ha mai dato il minimo problema

con alcune distro bisogna caricare anche cmpci perche il cuore è della cmedia ( specie con le debian based tipo knoppix )


con fedora dopo avere caricato i moduli
snd
soundcore
snd-via82xx

prova a dare un
generate-modprobe.conf


installa anche alsamixergui perche a volte succede che ci siano i canali disattivati
se hai messo il connetore delle casse all'uscita dolby mettilo nell'altra perche non sempre riconosce le varie porte della scheda

kentaromiura
14-03-2005, 15:11
Originariamente inviato da andy caps
:master: a me non ha mai dato il minimo problema

con alcune distro bisogna caricare anche cmpci perche il cuore è della cmedia ( specie con le debian based tipo knoppix )


con fedora dopo avere caricato i moduli
snd
soundcore
snd-via82xx

prova a dare un
generate-modprobe.conf


installa anche alsamixergui perche a volte succede che ci siano i canali disattivati
se hai messo il connetore delle casse all'uscita dolby mettilo nell'altra perche non sempre riconosce le varie porte della scheda
si, il modulo snd-cmipci viene caricato da modprobe quando fai modprobe snd-via82xx ..
forse e' un problema di alsa ..
stasera ricompilo alsa e poi riprovo.. :dottò:
ps. fedora non dà problemi ma le altre distro si..
comunque goglando trovi molte persone che hanno problema con quella scheda..
(personalmente ritengo che avere schede integrate non sia il massimo, anzi..)
:bhò:

andy caps
14-03-2005, 15:33
:bhò: tra quelle integrate è la migliore
io uso alsa e se serve (per alcuni giochi) metto in modules gli oss e carica quelli
con debian tempo fa dava problemini con il mixer ma installando un poi di file risolveva da se (apt-cache search mixer )

kentaromiura
14-03-2005, 15:56
Originariamente inviato da andy caps
:bhò: tra quelle integrate è la migliore
io uso alsa e se serve (per alcuni giochi) metto in modules gli oss e carica quelli
con debian tempo fa dava problemini con il mixer ma installando un poi di file risolveva da se (apt-cache search mixer )
a proposito di giochi :D
in Fedora C3 mi va il suono, pero' quando gioco a Unreal non funzia..
sai il perchè?

Dario89
14-03-2005, 20:08
forse e' un problema di alsa ..

Sto per dire una stronzata, fermatemi finche siete a tempo..
troppo tardi ora la dico...;-)

Non è che magari hai anche un modem interno?

A me dava problemi quello con alsa perchè lo considerava una scheda audio e quindi non mi andava più, poi ho risolto (mi pare di ricordare) con un alsaconf...

andy caps
14-03-2005, 21:18
a proposito di giochi
in Fedora C3 mi va il suono, pero' quando gioco a Unreal non funzia..
sai il perchè?

:D per cosa credi carichi oss

metto i driver oss e ascolto i suoni con enemy territory

prova comunque ad installare nas e le varie librerie sdl

con gentoo va senza oss con quelle librerie

spesso come dice Dario89 scambia il modem per una scheda audio comunque con dmesg si vede

kentaromiura
15-03-2005, 09:17
Originariamente inviato da andy caps
:D per cosa credi carichi oss

metto i driver oss e ascolto i suoni con enemy territory

prova comunque ad installare nas e le varie librerie sdl

con gentoo va senza oss con quelle librerie

spesso come dice Dario89 scambia il modem per una scheda audio comunque con dmesg si vede
ho risolto (su arch linux)..
dopo aver fatto un
modprobe snd-viaxx
modprobe snd-cmipci

ho settato i volumi con alsamixer..
mettendo a MUTE il capture qualcosa.. :stordita: (sono molto preciso)
poi e' partito sia il suono sia Unreal Tournament 2003..
pero' quest'ultimo nel sonoro fa fruscii.. :dottò: (mplayer invece va da dio)

Loading