PDA

Visualizza la versione completa : Installiamo kde3.4.0 su Debian Sid e derivate


francofait
15-03-2005, 14:55
Come da titolo , installiamo sulla nostra distro la nuova versione Kde3.4.

1) editare il file /etc/apt/sources.list ed aggiungiamo questa repositri:
deb http://pkg-kde.alioth.debian.org/kde-3.4.0 ./

Disabilitare tutte le altre repositri commentandole

da console su root esguire : apt-get update per aggiornare il dabase locale

Aprire synaptic ed eseguire ' marca tutti gli aggiornamenti ' scegliendo e mandando quindi in esecuzione ' aggiornamento intelligente '

eseguito l'upgrade dei pacchetti con la repostri addizionale , non ancora il momento di riavviare x , rimane da eseguire l'aggiornamento
del loginmanager Kdm

2) Aggiornare KDM

Editare nuovamente /etc/apt/sources.list
commentare temporaneamente anche la repositri addizionale aggiunta in precedenza ed inserire temporaneamente la repositri ufficiale di Ubuntu Hoary

deb http://es.archive.ubuntu.com/ubuntu hoary main restricted


da console su root eseguire :

apt-get --reinstall -install kdm
dpkg-reconfigure kdm

3) A questo punto kde3.4 installato

Riavvare il SO

Eliminare la repositri ufficiale di Ubuntu e deccomentare riabilitando tutte le altre compresa quella da cui abbiamo eseguito l'upgrade a kde3.4


__________________________________________________ ____-___

Con Kde3.4 il gestore della Posta Kmail stato integrato in Kontact - per renderlo correttamente attivo quindi dovremo andare a modificare i comandi nel pannello di configurazione dei menu
Aprite la sezione ' Internet ' alla voce (con relativa icona) Kmail
e nel pannello comandi nel riquadro relativo al comado di esecuzione per Kmail modificate:

kmail -caption "%c" %i %m

in

kontact -caption "%c" %i %m


Problema Kmail risolto , ora un clic sulla sua icona nella traybar ve lo aprir correttamente.

alex86
15-03-2005, 15:13
..ok..ma nn credo di poter fare l'aggiornamento xk ad esempio non m permette di installare kdebase xk nn m risolve delle dipendenze..

francofait
15-03-2005, 15:23
Originariamente inviato da alex86
..ok..ma nn credo di poter fare l'aggiornamento xk ad esempio non m permette di installare kdebase xk nn m risolve delle dipendenze..

Solito sfigato , dopo avere eseguito l'istallazione kde3.4 su SimplyMepis io, ho messo la guida sia in Mepis Italia che in Debianitalia .org dove gi stata utilizzata con successo 84 volte senza problemi.
:D :D :D :D

francofait
15-03-2005, 15:31
Originariamente inviato da francofait
Solito sfigato , dopo avere eseguito l'istallazione kde3.4 su SimplyMepis io, ho messo la guida sia in Mepis Italia che in Debianitalia .org dove gi stata utilizzata con successo 84 volte senza problemi.
:D :D :D :D

Dal momento che sul mirror di Ubuntu hoary kde3.4 al momento attuale interamente presente e funzionale , al posto della repositri non ufficiale Debian puoi utilizzare quella ufficiale di Ubuntu hoary.
Tassativa per in questo caso la selezione manuale dei pachetti via synaptic , altrimenti fai un bel canaio. Nella repositri di Ubuntu non c' solo kde ma l'intera distribuzione di Ubuntu hoary x cui assolutamente no upgrade genrico intelligente -
Devi x forza procedere alla selezione manuale dei pacchetti , marcandoli x installazzione 1x1.

Per installare direttamente tutto da repositri ubuntu hoary inpostala
cos:
deb http://es.archive.ubuntu.com/ubuntu hoary universe multiverse

christian78
17-03-2005, 10:38
Ci sono gi i pacchetti della versione ufficiale di kde3.4? Vorrei fare l'upgrade ma non vorrei installare la versione rc...

un'altro piccolo dubbio: io come login manager uso gdm... comunque necessario installare o aggiornare kdm?
:ciauz:

francofait
17-03-2005, 12:03
Originariamente inviato da christian78
Ci sono gi i pacchetti della versione ufficiale di kde3.4? Vorrei fare l'upgrade ma non vorrei installare la versione rc...

un'altro piccolo dubbio: io come login manager uso gdm... comunque necessario installare o aggiornare kdm?
:ciauz:

si sono state aggiornate ieri sera , sia ubuntu hoary che
deb http://pkg-kde.alioth.debian.org/kde-3.4.0 ./
Se usi GDM , puoi fare tranquillamente a meno di KDM

christian78
17-03-2005, 20:01
E' normale che se cerco di fare l'upgrade non mi faccia selezionare il pacchetto kde-i18n-it ?

Mi esce questo errore da synaptic:

Dipende: kdelibs4 (>=4:3.4.0-1) ma 4:3.4.0-0pre1 verr installato

Come risolvo?

christian78
17-03-2005, 20:31
Cambio domanda:
io ho installato kde-i18n-it 3.3.2-1, se tengo questo e non lo aggiorno kde3.4 riesco ad installarla in italiano oppure solo in inglese?

E' importante che sia in italiano, perch il pc lo usa anche mio padre e l'inglese non lo mastica molto bene :)
Thx! :ciauz:

alex86
17-03-2005, 20:58
Originariamente inviato da francofait
si sono state aggiornate ieri sera , sia ubuntu hoary che
deb http://pkg-kde.alioth.debian.org/kde-3.4.0 ./
Se usi GDM , puoi fare tranquillamente a meno di KDM

b..saranno anke state aggiornate ma io ancora ho problemi!non riesco ad installare kdebase....

francofait
17-03-2005, 22:44
Originariamente inviato da alex86
b..saranno anke state aggiornate ma io ancora ho problemi!non riesco ad installare kdebase....

Non colpa mia se non non vuol saperne ne di kanotix 2005 ne di knoppix 3.8 - cambia distro e rimetti simplymepis o ubunto hoary :unz: :unz:, lo installi al volo su tutte 2

Loading