PDA

Visualizza la versione completa : DNS che cambiano da soli!!!


Fabiuz
16-03-2005, 22:33
Ciao a tutti!
Ho un problema che non riesco a risolvere...:

Allora, premetto che utilizzo un modem D-link 300T ADSL
E' da un p di tempo che i DNS di nel file resolv.conf cambiano da soli
e dai canonici 212.216.112.112 e 212.216.172.62 diventano uno solo
che il 217.141.109.143 ....

Ecco, sono davvero stanco di cambiarli ogni volta a mano !!
Come posso fare per risolvere questo problema??
Come mai fino ad un mese fa, questo non avveniva!!

Grazie mille a tutti!
:ciauz: :ciauz:

RockSteady
16-03-2005, 22:38
usi il dhcp?

Fabiuz
16-03-2005, 22:41
il DHCP interno al modem intendi??
si!

RockSteady
16-03-2005, 22:42
ok fai queste modifiche al file /etc/conf.d/net


iface_eth0="dhcp"
dhcpcd_eth0="-R"
#dhcpcd_eth0="..."
:ciauz:

Fabiuz
16-03-2005, 22:47
ma io non ho quel file!
al massimo ho rc.d/rc.inet1.conf (credo che intendessi questo)???

:ciauz:

RockSteady
16-03-2005, 22:49
non s che distro usi
io su gentoo ho questo file


[rocksteady@bboy] [pts/1] [etc] *22:40:34* $ cat /etc/conf.d/net
# /etc/conf.d/net:
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/conf.d/net,v 1.7 2002/11/18 19:39:22 azarah Exp $

# Global config file for net.* rc-scripts

# This is basically the ifconfig argument without the ifconfig $iface
#
iface_eth0="192.168.0.2 broadcast 192.168.0.255 netmask 255.255.255.0"
#iface_eth1="207.170.82.202 broadcast 207.0.255.255 netmask 255.255.0.0"

# For DHCP set iface_eth? to "dhcp"
# For passing options to dhcpcd use dhcpcd_eth?
#
iface_eth0="dhcp"
dhcpcd_eth0="-R"
#dhcpcd_eth0="..."

# For adding aliases to a interface
#
#alias_eth0="192.168.0.3 192.168.0.4"

# NB: The next is only used for aliases.
#
# To add a custom netmask/broadcast address to created aliases,
# uncomment and change accordingly. Leave commented to assign
# defaults for that interface.
#
#broadcast_eth0="192.168.0.255 192.168.0.255"
#netmask_eth0="255.255.255.0 255.255.255.0"


# For setting the default gateway
#
#gateway="eth0/192.168.0.1"

Fabiuz
16-03-2005, 22:52
io uso la slackware
!!!!!!!!!!!

RockSteady
16-03-2005, 23:02
non saprei quale sia il file su slack mi spiace :cry:

nickcrazy
16-03-2005, 23:31
Io ho avuto un problema simile al tuo, sul forum di Ubuntu (io uso questa distro), ho trovato questa dritta, da root digita ifdown eth0 , poi cambi il resolv.conf e metti i tuoi DNS, la discussione sul forum Ubuntu la trovi QUI (http://ubuntuforums.org/showthread.php?t=5690) dove mi sembra ci siano altre dritte, ma che riguardano Ubuntu, forse per una di questa pu andare bene anche a te :ciauz:

cacao74
16-03-2005, 23:35
Originariamente inviato da Fabiuz
ma io non ho quel file!
al massimo ho rc.d/rc.inet1.conf (credo che intendessi questo)???

:ciauz:
Hai sopratutto un file chiamato /etc/rc.d/rc.inet1.
Modifica la parte in cui viene utilizzato il client DHCP aggiungendo l'opzione che ti hanno suggerito per evitare che il file resolv.conf venga sovrascritto (man dhcpcd).
Estratto del file citato:


...
eth_up() {
...
if [ "${USE_DHCP[$1]}" = "yes" ]; then # use DHCP to bring interface up
if [ ! "${DHCP_HOSTNAME[$1]}" = "" ]; then
echo "/etc/rc.d/rc.inet1: /sbin/dhcpcd -d -t 10 -R -h ${DHCP_HOSTNAME[$1]} eth${1}" | $LOGGER
/sbin/dhcpcd -d -t 10 -R -h ${DHCP_HOSTNAME[$1]} eth${1}
else
echo "/etc/rc.d/rc.inet1: /sbin/dhcpcd -d -t 10 -R eth${1}" | $LOGGER
/sbin/dhcpcd -d -t 10 -R eth${1}
fi
...

Le parti in rosso sono quelle da aggiungere.
In ogni caso, un backup di questo file prima di fare qualunqie modifica, male non fa.

ciao

Loading