PDA

Visualizza la versione completa : Problemi con Swaret e Repository


Zero-2
21-03-2005, 12:59
Salve a tutti ,
dato che voglio aggiornare kde alla nuova versione 3.4.0 e dato che ho trovato i pacchetti su linuxpackages e dato che voglio fare l'upgrade tramite swaret,ho aggiunto il Repository di linuxpackages .Do swaret --update e mi dice questo


[ ftp://ftp3.linuxpackages.net/pub/Slackware-10.1 ]
### Fetching 'LinuxPackagesDOTNET' CHECKSUMS List File...
--11:51:34-- ftp://ftp3.linuxpackages.net/pub/Slackware-10.1/CHECKSUMS.md5
=> `CHECKSUMS.md5'
Resolving ftp3.linuxpackages.net... 64.90.191.130
Connecting to ftp3.linuxpackages.net[64.90.191.130]:21... connected.
Accesso come utente anonymous ... Login eseguito!
==> SYST ... fatto. ==> PWD ... fatto.
==> TYPE I ... fatto. ==> CWD /pub/Slackware-10.1 ... fatto.
==> PASV ... fatto. ==> RETR CHECKSUMS.md5 ... fatto.
Lunghezza: 46,975 (non autorevole)

100%[===========================================>] 46,975 36.90K/s

11:51:38 (36.83 KB/s) - `CHECKSUMS.md5' salvato [46975]

'LinuxPackagesDOTNET' FILELIST List File is up-to-date!
'LinuxPackagesDOTNET' Packages Descriptions up-to-date!

per quando scrivo swaret --upgrade kde mi dice che i pacchetti sono gi aggiornati e non mi mostra quelli del repository :(
C' qualche procedura particolare? Sul sito di swaret non ho trovato nulla...
Ho provato anche a togliere il ROOT e ridare swaret --update , ma nulla....

:(

andy caps
21-03-2005, 15:13
:bh: a me lo sta aggionando

metti in swaret.conf

REPOS_ROOT=linuxpackages.net%http://www2.linuxpackages.net/packages/Slackware-10.1/

commentando la precedente se non va



New: kdeaddons-3.4.0-i486-1jim (236 kB) (linuxpackages.net) - Installed: kdeaddons-3.3.2-i486-1
New: kdeadmin-3.4.0-i486-1jim (1445 kB) (linuxpackages.net) - Installed: kdeadmin-3.3.2-i486-1
New: kdeartwork-3.4.0-i486-1jim (17623 kB) (linuxpackages.net) - Installed: kdeartwork-3.3.2-i486-1
New: kdebase-3.4.0-i486-1jim (26797 kB) (linuxpackages.net) - Installed: kdebase-3.3.2-i486-1
New: kdegames-3.4.0-i486-1jim (9834 kB) (linuxpackages.net) - Installed: kdegames-3.3.2-i486-1
New: kdegraphics-3.4.0-i486-1jim (8497 kB) (linuxpackages.net) - Installed: kdegraphics-3.3.2-i486-3
New: kdelibs-3.4.0-i486-1jim (18292 kB) (linuxpackages.net) - Installed: kdelibs-3.3.2-i486-2
New: kdemultimedia-3.4.0-i486-1jim (8098 kB) (linuxpackages.net) - Installed: kdemultimedia-3.3.2-i486-1

Zero-2
21-03-2005, 15:30
ufffffffffffffffffff :dh: :dh: :dh:


swaret --upgrade kde
swaret 1.7.0test4-1

=> Creating EXCLUDE List..... DONE!

Listing available Packages matching Keyword: kde...

Installed Packages are up-to-date matching Keyword: kde!

ma la versione che ho installata la 3.3.2 :(
ma che versione hai?

andy caps
21-03-2005, 15:49
dai uno swaret --search kde e guarda che dice

il meta pacchetto kde puo darsi che non ci sia

io ho dato un swaret --upgrade -a

Zero-2
21-03-2005, 16:18
Purtroppo non c' nel search :( nemmeno nel list...
Ma che ne so...

Zero-2
21-03-2005, 16:34
Dalla disperazione ho dato un bel purge , cancellato tutta la dir e ridato lo swaret --update e ora funziona....
Mah... :jam: :jam:

edriv
13-06-2005, 15:41
ma esiste un repository che abbia almeno openoffice?
Devo per forza scaricarlo a mano?

andy caps
13-06-2005, 16:07
http://www.linuxpackages.net/pkg_details.php?id=6600

il pacchett oslack lo trov qui probabilmente mettendo linuxpackages.net lo trova

linuxpackages.net meglio commentarle poi perche secondo me fa anche pasticci

a me uno swaret --upgrade -a toglieva molti pacchetti a 32 per mettere quelli a @64

Enrico.dg
13-06-2005, 19:07
ciao io ho inserito la dicitura current come versione della slackware, e facendo swaret --upgrade kde mi ha messo la kde-3.4, senza utilizzare le repository di linuxpackages.

Loading