PDA

Visualizza la versione completa : far partire l'interfaccia grafica di kde all'avvio come si fa?


franco112
23-03-2005, 12:21
ho un problema con Suse 9.1 non riesco a far partire l'interfaccia grafica di kde all'avvio come si fa?
tra l'altro volevo passare dall'utente di avvio all'utente root e ho digitato "su" in corrispondeza della riga di comando che mi si presentava, poi è comparsa la richiesta della password è ho digitato quella di root ma non riesco ad accedere all'utente root, come si fà a passare da un utente all'utente root da riga di comando ?

scusate la banalità delle mie domande ma sono nuovo della materia....
ciauz

eraclito
23-03-2005, 13:04
Originariamente inviato da franco112
ho un problema con Suse 9.1 non riesco a far partire l'interfaccia grafica di kde all'avvio come si fa?
tra l'altro volevo passare dall'utente di avvio all'utente root e ho digitato "su" in corrispondeza della riga di comando che mi si presentava, poi è comparsa la richiesta della password è ho digitato quella di root ma non riesco ad accedere all'utente root, come si fà a passare da un utente all'utente root da riga di comando ?

scusate la banalità delle mie domande ma sono nuovo della materia....
ciauz

per passare all'utente root il procedimento illustrato è corretto.

ti da messaggi di errore?

trillullero
23-03-2005, 13:20
1-dopo aver installato suse ti trovi un login grafico oppure un terminale?

Mi sembra strano che il server x non ti parta all' avvio.

Per lanciare il serverx digita:
startx

Se vuoi avere la possibilità di cambiare dekstop manager digita
kdm
da root.

Poi usa yast per impostare l' avvio di x al boot.
Per farlo da terminale devi mettere mano nel file /etc/inittab.
Per poterlo fare dovresti imparare prima l' uso essenziale dell' edito di testi VI (prova eventualmente con vimtutor).

Questi 2 link ti possono aiutare a capire meglio come funzioni la grafica in linux:

http://forum.html.it/forum/showthread.php?s=&threadid=778013

http://forum.html.it/forum/showthread.php?s=&threadid=714300

franco112
23-03-2005, 13:55
Originariamente inviato da trillullero
1-dopo aver installato suse ti trovi un login grafico oppure un terminale?

Mi sembra strano che il server x non ti parta all' avvio.

Per lanciare il serverx digita:
startx

Se vuoi avere la possibilità di cambiare dekstop manager digita
kdm
da root.

Poi usa yast per impostare l' avvio di x al boot.
Per farlo da terminale devi mettere mano nel file /etc/inittab.
Per poterlo fare dovresti imparare prima l' uso essenziale dell' edito di testi VI (prova eventualmente con vimtutor).

Questi 2 link ti possono aiutare a capire meglio come funzioni la grafica in linux:

http://forum.html.it/forum/showthread.php?s=&threadid=778013

http://forum.html.it/forum/showthread.php?s=&threadid=714300

grazie ad entrambi troppo gentili. ciauz

franco112
23-03-2005, 14:23
Originariamente inviato da trillullero
1-dopo aver installato suse ti trovi un login grafico oppure un terminale?

Mi sembra strano che il server x non ti parta all' avvio.

Per lanciare il serverx digita:
startx

Se vuoi avere la possibilità di cambiare dekstop manager digita
kdm
da root.

Poi usa yast per impostare l' avvio di x al boot.
Per farlo da terminale devi mettere mano nel file /etc/inittab.
Per poterlo fare dovresti imparare prima l' uso essenziale dell' edito di testi VI (prova eventualmente con vimtutor).

Questi 2 link ti possono aiutare a capire meglio come funzioni la grafica in linux:

http://forum.html.it/forum/showthread.php?s=&threadid=778013

http://forum.html.it/forum/showthread.php?s=&threadid=714300

purtroppo mi dà questo messaggio di errore:
you did not install any X-Server \(e.g. XF86_SVGA)! please install at least one server to start X
I'm aborting now

si era sempre aperta automaticamente l'interfaccia grafica di kde, purtroppo mi è andata via la corrente e patatrac...

cosa potrei fare adesso ?

andy caps
23-03-2005, 14:37
se riesci a fare il login di root devi insatallare xserver

digita yast ed installa xserver
dovrebbe darti l'installatore di pacchetti anche senza xserver

altrimenti digita

yast -i XFree86

yast -i Xfree86-server

cosi tui i installa xserver che stranamente non ti ha installato
se hai problemi con i pacchetti scaricali da qui ftp://ftp.suse.com/pub/suse/i386/9.1/suse/i586/

franco112
23-03-2005, 14:42
Originariamente inviato da andy caps
se riesci a fare il login di root devi insatallare xserver

digita yast ed installa xserver
dovrebbe darti l'installatore di pacchetti anche senza xserver

altrimenti digita

yast -i XFree86

yast -i Xfree86-server

cosi tui i installa xserver che stranamente non ti ha installato
se hai problemi con i pacchetti scaricali da qui ftp://ftp.suse.com/pub/suse/i386/9.1/suse/i586/

provo subito grazie a tutti ciauz

franco112
23-03-2005, 17:05
Originariamente inviato da andy caps
se riesci a fare il login di root devi insatallare xserver

digita yast ed installa xserver
dovrebbe darti l'installatore di pacchetti anche senza xserver

altrimenti digita

yast -i XFree86

yast -i Xfree86-server

cosi tui i installa xserver che stranamente non ti ha installato
se hai problemi con i pacchetti scaricali da qui ftp://ftp.suse.com/pub/suse/i386/9.1/suse/i586/

niente da fare ho provato a fare come mi hai detto ma poi al riavvio mi si presenta il login testuale e dopo aver digitato nome utente e password mi rimane la schermata su riga di comando.....

mykol
23-03-2005, 17:11
ma se quando sei utente normale (dalla console, da riga di comando) dai

$ startx

e poi premi invio che succede ?

franco112
23-03-2005, 17:27
Originariamente inviato da mykol
ma se quando sei utente normale (dalla console, da riga di comando) dai

$ startx

e poi premi invio che succede ?

allora considera che io dopo aver digitato nome utente e password mi compare questo:

utente1:~ #

se digito: utente1:~ # $ startx
mi compare: - bash: $ command not found

:bhò:

Loading