PDA

Visualizza la versione completa : e le gtk??


morfeus
24-03-2005, 21:57
allora, scaricato e scompattato il kernel, ho ubuntu, dato make mrproper, non ho un .config da nessuna parte, do:



root@ubuntu:/usr/src/linux # make xconfig
*
* Unable to find the QT installation. Please make sure that the
* QT development package is correctly installed and the QTDIR
* environment variable is set to the correct location.
*
make[1]: *** [scripts/kconfig/.tmp_qtcheck] Error 1
make: *** [xconfig] Error 2


root@ubuntu:/usr/src/linux # make gconfig
*
* Unable to find the GTK+ installation. Please make sure that
* the GTK+ 2.0 development package is correctly installed...
* You need gtk+-2.0, glib-2.0 and libglade-2.0.
*
make[1]: *** [scripts/kconfig/.tmp_gtkcheck] Error 1
make: *** [gconfig] Error 2


???
vorrei evitare menuconfig...
poi magari vorrei sapere come caricargli la configurazione gi presente in modo da mettergli solo i moduli che mi servono.. come procedo?

/dev/null
24-03-2005, 22:12
Bhe', apt-get installati le gtk+-2.0, glib-2.0 e libglade-2.0...
Per quanto riguarda il .config del kernel copia quello che hai gia' in /usr/src/linux: dovrebbe importartelo automaticamente :)

:ciauz:

morfeus
24-03-2005, 22:41
Originariamente inviato da /dev/null
Bhe', apt-get installati le gtk+-2.0, glib-2.0 e libglade-2.0...
Per quanto riguarda il .config del kernel copia quello che hai gia' in /usr/src/linux: dovrebbe importartelo automaticamente :)

:ciauz:




apt-get install gtk+-2.0 glib-2.0 libglade-2.0 Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
E: Impossibile trovare gtk+-2.0


eppure le repository ce ne ho! :bh:

Ikitt
24-03-2005, 22:53
Originariamente inviato da Morfeus
[...]
eppure le repository ce ne ho! :bh:


apt-get install libgtk2.0-dev

morfeus
25-03-2005, 00:00
Originariamente inviato da Ikitt


apt-get install libgtk2.0-dev



ok per le gtk.. ma gli altri pacchetti? :bh:

fra l'altro mi d errore anche con make menuconfig, poi non ho il .config
e poi non capisco una cosa:

andrew@ubuntu:/usr/src/linux $ whereis glib-2.0
glib-2: /usr/lib/glib-2.0 /usr/include/glib-2.0 /usr/share/glib-2.0
andrew@ubuntu:/usr/src/linux $

le livrerie ci sono tutte, per non le trova, come mai? :zizi:

GhePeU
25-03-2005, 02:03
ti servono anche i pacchetti -dev forse?

Ikitt
25-03-2005, 08:53
Originariamente inviato da Morfeus
ok per le gtk.. ma gli altri pacchetti? :bh:


$ apt-cache depends libgtk2.0-dev
libgtk2.0-dev
Depends: libgtk2.0-0
Depends: libglib2.0-dev
Depends: libpango1.0-dev
Depends: libatk1.0-dev
|Depends: libx11-dev
Depends: xlibs-dev
|Depends: libxext-dev
Depends: xlibs-dev
Depends: pkg-config
Suggests: libgtk2.0-doc
Conflicts: <libgtk1.3-dev>
Replaces: <libgtk1.3-dev>

Vengono installati automaticamente in quanto dipendenze.


le livrerie ci sono tutte, per non le trova, come mai? :zizi:
Perche` per compilare del software che usa quelle librerie servono i pacchetti di sviluppo relativi. I -dev insomma.
(PS: e` una FAQ :fagiano: )

Loading