PDA

Visualizza la versione completa : No adsl con kernel nuovo!


makbell
26-03-2005, 19:16
Ciao a tutti,
sulla mia Slack 10 ho appena installato il kernel 2.6.10 al posto del 2.4.26 precedente.Purtroppo adesso non riesco a far funzionare l'adsl. Siccome ho un router Alcatel Speed Touch Pro, prima mi bastava lanciare "dhcpcd" da root e mi si configurava la scheda, mentre ora il comando resta in esecuzione senza dare risultati e devo fermarlo (Ctrl-c).Con ifconfig mi si configura la scheda, ma non riesco a pingare il router.Vi posto la parte del dmesg che riguarda l' eth0:
Mar 26 18:28:36 slackmak kernel: NETDEV WATCHDOG: eth0: transmit timed out
Mar 26 18:28:36 slackmak kernel: eth0: link up, 10Mbps, half-duplex, lpa 0x0000
Mar 26 18:30:24 slackmak kernel: NETDEV WATCHDOG: eth0: transmit timed out
Mar 26 18:30:24 slackmak kernel: eth0: link up, 10Mbps, half-duplex, lpa 0x0000
Mar 26 18:30:36 slackmak kernel: NETDEV WATCHDOG: eth0: transmit timed out
Mar 26 18:30:36 slackmak kernel: eth0: link up, 10Mbps, half-duplex, lpa 0x0000
Mar 26 18:31:20 slackmak pppd[5134]: pppd 2.4.2 started by root, uid 0
Mar 26 18:31:20 slackmak pppd[5134]: Using interface ppp0
Mar 26 18:31:20 slackmak pppd[5134]: Connect: ppp0 <--> /dev/pts/2
Mar 26 18:31:42 slackmak kernel: NETDEV WATCHDOG: eth0: transmit timed out
Mar 26 18:31:42 slackmak kernel: eth0: link up, 10Mbps, half-duplex, lpa 0x0000
Mar 26 18:31:51 slackmak pppd[5134]: Connection terminated.
Mar 26 18:31:55 slackmak pppd[5134]: Exit.
Qualcuno ne capisce qualcosa? :bh:

Fabiuz
26-03-2005, 21:39
non che devi usare la 100 mb/s al posto della 10 mb/s ???

osvi
26-03-2005, 22:39
prova dhclient

makbell
28-03-2005, 00:37
:master: Per quanto riguarda la 10 o la 100 mb/s non saprei come cambiarla, mentre per il dhclient ho gi provato a lanciare tutti gli scripts dhc...,ma senza risultati. :bh:

gio14
28-03-2005, 01:04
In slack prova ha lanciare netconfig

mschievano
28-03-2005, 14:48
non funziona con adsl-setup come tutti i modem?

osvi
28-03-2005, 14:53
Originariamente inviato da mschievano
non funziona con adsl-setup come tutti i modem?
non tutti, quelli over eth :fagiano:

e questo un router poi

osiryx
28-03-2005, 15:15
Hai controllato di aver correttamente compilato il kernel...tra la versione 2.4 e la 2.6 ci sono nn poche differenze...
Che scheda di rete ?
Prova a dare ifconfig eth0 192.168.1.2 up alla scheda di rete e ad entrare nel router tramite browser per vedere se tutto apposto
Nel browser devi mettere 192.168.1.1

danido3
28-03-2005, 15:51
ti do un indirizzo:

linuxzine (http://www.linuxzine.it)

controlla nella sezione articoli, c' un articolo che riguarda la connessione internet con kernel 2.6 penso che ti possa dare una mano a risolvere tutti i problemi.

Facci sapere

Loading