PDA

Visualizza la versione completa : Crash sistemativo


Ecatonchiro
14-04-2005, 18:11
Salve a tutti...
sono un po' perplesso circa un crash che
si verifica sistematicamente al umount della mia penna USB...

vi spiego, sono su Ubuntu, ho predisposto il mio fstab
affinché mi monti la penna in


/dev/sda1 /media/pendrive vfat noauto,user,iocharset=iso8859-15 0 0

che mi rende perplesso già al momento dell'inserimento
della penna è il fatto che compaia in automatico una finestrella di Nautilus con la cartella Pendrive...

ma come, non avevo specificato "NOAUTO"??

Vabé, su questo ho sorvolato... che invece mi spinge a chiedere consiglio a voi è il fatto che 2 volte su 3 al comando

umount /media/pendrive

il sistema si blocca...
e con "blocca" intendo che non posso far altro che spegnere forzatamente la macchina!

Mai successa una cosa del genere, né su Slackware né su Mandrake... avete suggerimenti?

gianiaz
14-04-2005, 20:05
provato a smontare da nautilus?

sicuro che non ci sia qualche cosa riguardo l'automounter magari in qualche altra riga nell'fstab?

makbell
14-04-2005, 23:10
ma come, non avevo specificato "NOAUTO"??
"AUTO" significa che il filesystem viene montato quando è lanciato il comando < mount -a > ( es.: al boot). X quanto riguarda il crash non saprei; ti crasha anche se dai "umount /dev/sda1"?
Ciao.

:ciauz:

Ecatonchiro
16-04-2005, 12:12
1. Anche smontando da Nautilus si verifica il crash
2. Non ho ancora provato il suggerimento di smontare il sda1 perché ormai vivo nel terrore dell'umount:]


vorrei capire come mai su ubuntu si verifica il montaggio automatico alla connessione della penna alla presa usb. (un'intuizione forse erronea mi indirizza a cercare le origini del problema qui)

vi posto il mio fstab così com'è



# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda3 / ext3 defaults,errors=remount-ro 0 1
/dev/hdb4 /mnt/Documenti vfat auto,user,rw,umask=000 0 0
/dev/hdb2 /mnt/MP3 vfat auto,user,rw,umask=000 0 0
/dev/hdb3 /mnt/Swap vfat auto,user,rw,umask=000 0 0
/dev/hdb1 /mnt/Video vfat auto,user,rw,umask=000 0 0
/dev/hda4 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/sda1 /media/pendrive vfat noauto,user,iocharset=iso8859-15 0 0




Grazie ad entrambi per le risposte.

vampirla
16-04-2005, 14:55
anche a me lo faceva,e la chiavetta che da conflitti :dhò:

Loading