PDA

Visualizza la versione completa : Aggiornare Glib


kioto
25-04-2005, 10:40
Ragazzi ieri volevo provare ad installare le nuove GTk purtroppo non ci sono riuscito ma il problema più grosso
e che molte applicazioni non mi funzionano.
Le Glib 2.4.6 risultano installate da pkgtool.
Io pcredo che sia un problema di path come posso risolvere
questa cosa ?
Grazie e scusatemi ma ho molte applicazioni k.o

andy caps
25-04-2005, 11:55
http://developer.gnome.org/doc/API/2.0/gtk/gtk-building.html

dai un occhiata qui :bhò:
se ti ha sostituito le librerie vecchie con le nuove è normale che molte applicazioni non vadano
avviale da consolle e guarda eventualmente di linkargli le librerie manualmente se indicano la posizione in cui le cercano

prova a reistallare le vecchie

kioto
25-04-2005, 13:02
Mi dicono solo i moduli che mancano non il relativo path.
I programmi puntano alle librerie /usr/lib/ sono convinto
perché erano quello installati insieme alla distro.
Mi spieghi come modificare i path necessari.
Non perché non abbia voglia di leggere ma perché vorrei limitare i danni.
Grazie

andy caps
25-04-2005, 13:06
in genere si fa un link

se una libreria la cerca in /usr/lib ed invece è in /opt/gtk/lib ad esempio vai in usr/lib e fai un link

cd /usr/lib

ln -s /opt/gtk/lib/libgtk.xxxx
cosi poi trova la libreria
spesso è un lavoro certosino

kioto
25-04-2005, 13:37
Ho scaricato le Glib 2.4.2 quelle che facevano della Slack.
Ho compilato ed installato queste /usr/local/lib/glib-2.0
Ho creato in /usr/lib/glib un link a quelle in /usr/local...
Ne ho combinato un altra delle mie :D :D
Cmq le Gtk devo impararlea compilare e configurare a manina
perchésono indispensabili.

doctorGra
21-11-2006, 13:54
ciao,
anche io ho lo stesso problema o simile, premetto che sono novello (come il vino) di linux, ho installato da sorgente (e quindi manualmente seguendo il file install) la libreria Glib 2.x, il tutto è andato a buon fine se non che al riavvio o avuto la sorpresa, molte applicazioni (firefox gimp gestore batteria ecc) non funzionano più, ho pensato anche io ad un fattore di modifica dei link ma non so completamente dove mettere le mani per rimediare, visto che ho installato la distro suse 10.1 più volte pensando di aver fatto un errore nella compilazione della libreria glib, che mi serve. spero possiate aiutarmi visto che non funzionando più il gestore della batteria il portatile mi si spegne senza dire niente, perdendo le info, e viaggia sempre al max con il rischio di eccessivo surriscaldamento.
Grazie in anticipo.

andy caps
21-11-2006, 14:22
guarda da yast2 rimuovendo e reinstallando i programmi che non vanno se ti propone di downgradare glib

doctorGra
21-11-2006, 17:10
Ho già visto da yast, se potevo aggiornare la glib, ma mi dice che la versione installata è la glib 1.2.10-607, e non ci sono aggiornamenti, pultroppo per una particolare applicazione ho la necessità di utilizzare la glib versione >=2 e ho trovato nel sito www.gtk.org il sorgente da installare. Ho installato il sorgente, l'applicazione funziona, ma tutto il resto no.

Dr. Fiemost
21-11-2006, 17:28
Originariamente inviato da doctorGra
Ho già visto da yast, se potevo aggiornare la glib
Il pacchetto glib si riferisce alla versione 1.x, per la 2.x il pacchetto si chiama glib2.

doctorGra
21-11-2006, 17:38
il problema è un'altro io ho la necessità sia di glib2 che di glib versione >=2.x, cioè quello che yast individua come glib 1.2.10-607 ma versione superiore alla 1.2.x.
Infatti se non installo la glib scaricato dal sito www.gtk.org l'applicazione che mi necessita non parte.
(può essere che glib2 non sia la versione 2.x di glib)

Loading