PDA

Visualizza la versione completa : [debian] X.org e problema tastiera.


HIEI
02-05-2005, 09:31
Ciao a tutti. Sono riuscito a installare x.org su sid prendendola dai repository di breezy. L'unico problema riscontrato fino ad ora Ŕ l'impossibilitÓ di utilizzare i caratteri creati con il tasto alt ("[", "@" ecc...). Questo si traduce anche nell'impossibilitÓ di passare da xserver ad una console con la combinazione alt + F#. Qualcuno sa come risolvere questo piccolo inconveniente?

Grazie mille.

HIEI
03-05-2005, 09:31
up

side-server
03-05-2005, 12:51
molto probabilmente ti ha cambiato il layout di tastiera, devi riconfigurarlo
prova con dpkg-reconfigure xserver-xorg (se non ricordo male il pacchetto Ŕ quello)

:ciauz:

edit: qual'Ŕ il repository? Ŕ uno per ubuntu o proprio per debian?

andy caps
03-05-2005, 13:56
guarda se hai decommentato in xorg.conf una tastiera it a 104 tasti
guarda se va
dpkg-reconfigure console-data
e scegli una qwerty it@euro

HIEI
03-05-2005, 14:56
Ok ora provo grazie.

@Side-server: Il repository Ŕ quello univers di breezy.

side-server
03-05-2005, 16:04
Originariamente inviato da HIEI
@Side-server: Il repository Ŕ quello univers di breezy.

ubuntu quindi :dh˛:

peccato :D

HIEI
03-05-2005, 16:31
GiÓ purtroppo ancora non c'Ŕ per sid.

Andy il metodo che mi hai consigliato purtroppo non ha funzionato...

aristarkos
03-05-2005, 18:57
Ho un problema analogo con Gentoo 2005.0: ho installato X ed eseguito xorgconfig: funziona tutto benissimo tranne il tasto AltGr ke viene completamente ignorato, per cui non riesco a scrivere tutta una serie di caratteri.. Ho provato a modificare in vari modi le impostazioni della tastiera in xorg.conf ma nulla da fare..

Qualke idea??
Grazie

andy caps
03-05-2005, 20:09
io in genere uso XF86Config-4 anche con xorg
se ne hai uno funzionante basta rinominare xorg.conf

e fare un link in /etc/X11
ln -s XF86Config-4 xorg.conf

fai una prova
commenta la sezione della tastiera e mettici questa

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "compose:rwin"
EndSection


o quella di debian

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "it"
EndSection

con gentoo a me va perfettamente

aristarkos
03-05-2005, 20:48
E' stata un po' un impresa riuscire a commentare la sezione senza poter scrivere i caratteri #, ma adesso funziona alla perfezione (anke con xorg.conf).. :)

Grazie mille andy!

Loading