PDA

Visualizza la versione completa : [Gentoo] Grub - newbie


killer79
02-05-2005, 11:27
Ciao,


dopo essere riuscito a completare l'installazione di Gentoo, ho un problema con Grub.

La domanda è niubba come da titolo del pos....

Per modificare la configurazione del Grub utilizzo il liveCD,poi faccio il mount delle partizioni e poi vado su /boot/grub/grub.conf??



Grazie

hope for us
02-05-2005, 11:43
Monti le partizioni, fai il chroot, editi /boot/grub/grub.conf e poi lanci il comando

grub-install --root-directory=/boot /dev/hda

poi fai

exit
cd
umount /mnt/gentoo/proc /mnt/gentoo/boot /mnt/gentoo
reboot

killer79
02-05-2005, 11:49
Grazie,
stasera provo.

hope for us
02-05-2005, 11:52
Di nulla, ciao :ciauz:

killer79
03-05-2005, 08:54
Ho seguito le tue istruzioni e sono riuscito a modificare la configurazione del grub, ma continuavo ad avere problemi: non mi dava la schermata con indicato il kernel inserito nel grub.conf.
si fermava a grub>

Ho provato a dare 'kernel percorso e nome kernel ' e poi boot
e si piantava, ma non penso sia la procedura corretta.

Alla fine ho installato LILO con le stesse impostazioni di GRUB e funziona a meraviglia.

Non ho la configurazione del grub sotto mano, ma magari la posto domani... Se qualcuno può darmi una dritta per farlo funzionare...


PS:finalmente la mia GENTOO 2005 gira!!!!!! Una soddisfazione incalcolabile!! :unz: :) :ciauz:

Grazie ancora

hope for us
03-05-2005, 12:53
Questo è il mio grub.conf:
#
# Sample boot menu configuration file
#

# Boot automatically after 30 secs.
timeout 30

# By default, boot the first entry.
default 0

# Fallback to the second entry.
fallback 1

# For booting GNU/Hurd
#title GNU/Hurd
#root (hd0,0)
#kernel /boot/gnumach.gz root=hd0s1
#module /boot/serverboot.gz
splashimage=(hd0,4)/grub/penguins.xpm.gz


# For booting GNU/Linux
title=Gentoo Linux 2.6.11-r6
root (hd0,4)
kernel /kernel-2.6.11-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 reaoot=/dev/hda7
initrd /initrd-2.6.11-gentoo-r6

# For booting Mach (getting kernel from floppy)
#title Utah Mach4 multiboot
#root (hd0,2)
#pause Insert the diskette now!!
#kernel (fd0)/boot/kernel root=hd0s3
#module (fd0)/boot/bootstrap

# For booting FreeBSD or GNU/KFreeBSD
#title FreeBSD / GNU/KFreeBSD
#root (hd0,2,a)
#kernel /boot/loader

# For booting NetBSD or GNU/KNetBSD
#title NetBSD / GNU/KNetBSD
#root (hd0,2,a)
#kernel --type=netbsd /netbsd

# For booting OpenBSD
#title OpenBSD
#root (hd0,2,a)
#kernel --type=netbsd /bsd

# For booting OS/2
#title OS/2
#root (hd0,1)
#makeactive
# chainload OS/2 bootloader from the first sector
#chainloader +1
# This is similar to "chainload", but loads a specific file
#chainloader /boot/chain.os2

# For booting Windows NT or Windows95
title=Windows XP Professional
root (hd0,0)
makeactive
chainloader +1

# For loading DOS if Windows NT is installed
# chainload /bootsect.dos

# For installing GRUB into the hard disk
#title Install GRUB into the hard disk
#root (hd0,0)
#setup (hd0)

# Change the colors.
#title Change the colors
#color light-green/brown blink-red/blue

Lo salvi in /boot/grub/grub.conf e poi dai

grub-install

Al prompt di grub fai:


grub> root (hd0,4)
grub> setup(hd0)
quit

Considera che la mia /boot è hda5 quindi devi vedere dove ce l'hai tu (se è in hda1 ad esempio metti invece di (hd0,4) (hd0,0)

killer79
03-05-2005, 13:56
CIauz

Finora ho utilizzato la configurazione di base che è presentata sull'handbook della 2005 per gli utenti che non hanno usato genkernel.

Effettivamente io ho il boot su hda1 ed avevo settato (hd0,0) e le uniche due righe differenti sono queste (oltre alla splashimage)

kernel /kernel-2.6.11-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 reaoot=/dev/hda7
initrd /initrd-2.6.11-gentoo-r6

io ho solo questo

kernel /kernel-2.6.11-gentoo-r3 root=/dev/hda3

e non ho l'initrd

hope for us
03-05-2005, 14:11
Ah si scusa, è che io ho usato genkernel. La riga root (hd0,0) l'hai messa? Dovresti avere:



root (hd0,0)
kernel /kernel-2.6.3-gentoo-r3 root=/dev/hda3

Sei sicuro di quale versione di kernel hai e di quali sonbo le tue partizioni di boot e root?

PS: Il comando era solo grub, non grub-install...

hope for us
03-05-2005, 14:16
Ah scusa, avevo saltato il post in cui dici che la Gentoo va... :D Che coglione!!!!!!!

PS: Goditi la Gentoo, è la distro + bella che potessi mai trovare... :ciauz:

killer79
03-05-2005, 14:26
Grazie ancora,

erano un paio di settimane che cercavo di farla andare..

Adesso comincia il bello:

Ho deciso di usarla per fare un Media Center.


Pentium 4 Celeron 2.4
512MB ram DDR FSB 400
MotherBoard ASROCK PVM8(costava poco)
HD IDE 60 GB
Masterizz. DVD Lite-on
Geforce MX440 (Uscita Tv per collegarlo al TV)
Sound Blaster Live!

adesso prenderò il telecomando della ATI consigliato su un numero di Linux Magazine

Più avanti pensavo di montargli la scheda della hauppauge per registrare il video su HD.

So che per un niubbo come me sarà dura, ma ho un sacco di voglia di smanettare e non ho fretta, quindi...

:) :unz:

Loading