PDA

Visualizza la versione completa : DEBIAN: nessun terminale di login


Cimi
02-05-2005, 12:15
(installazione nuova)
Raga da anni che compilo kernel... non so...
se booto con il kernel precompilato di debian tutto funziona, se booto con il mio kernel appena compilato dopo l'avvio dei vari demoni (l'ultimo cron) si blocca e nn mi avvia nessun terminale da cui fare il login. Dopo due tre minuti di blocco (in ogni caso non un crash totale perch posso scrivere con la tastiera ma totalmente ininfluente ci che scrivo) mi da un init: id "0x" respawning too fast (dove x va da 1 a 6)
Nel config del kernel c' il supporto alla console...

andy caps
02-05-2005, 13:29
guarda che ci sia il supporto per le porte seriali i font dei terminali l'interfacia di looopback
di cose possibili se ce sono parechie

Cimi
02-05-2005, 17:51
Originariamente inviato da andy caps
guarda che ci sia il supporto per le porte seriali i font dei terminali l'interfacia di looopback
di cose possibili se ce sono parechie
seriali s... font terminali 8x16... ma cmq anche senza framebuffer non va... il loopback in modulo...

andy caps
02-05-2005, 19:42
http://www.unixguide.net/linux/faq/09.24.shtml

:bh: prova a compilare un kernel diverso o parti dalla mia conf e riadattala

wget andycaps.it/config

Cimi
02-05-2005, 20:23
Originariamente inviato da andy caps
http://www.unixguide.net/linux/faq/09.24.shtml

:bh: prova a compilare un kernel diverso o parti dalla mia conf e riadattala

wget andycaps.it/config
ho compilato il 2.4.27 e il *.30
in quel pc sempre funzionato il 2.4... e avevo debian fino a 2 settimane fa, poi ho messo ubuntu, poi archlinux per vedere se col 2.6 andava meglio (la mia scheda video ha i driver per il 2.4 su xfree 4.3, mentre per xorg ce li ha su 2.6)...
poi ho rimesso debian

Cimi
04-05-2005, 19:05
up

andy caps
04-05-2005, 19:54
prova ad incollare il .config del kernel :bh:

Cimi
05-05-2005, 14:20
Originariamente inviato da andy caps
prova ad incollare il .config del kernel :bh:
nn credo c'entri compilato come sempre... :bh:

RaouL_BennetH
06-05-2005, 01:25
Ho trovato questo, non so se pu aiutarti:

" If you don't get a login prompt, or you see a console message like: "respawning too fast....
disabled for five minutes" (check your /var/log/messages file for this and similar errors
from init and/or from any 'getty' that you happen to be using), you should double-check the
syntax of your entry, double-check which serial port you're plugged into (remember Linux' numbering of
serial and printer ports sometimes doesn't correspond to DOS/BIOS extensions --- some crufty hardware
may cause confusion), and check for IRQ conflicts and cabling errors. "

Loading