PDA

Visualizza la versione completa : Problema di boot


pesci74
03-05-2005, 13:34
Ho installato Linux sul mio computer. Prima avevo 2 partizioni nell'Hard disk: la prima C conteneva Windows XP pro, la seconda D Windows 2000. Installando Mandrake Linux con il suo CD ho voluto fare in modo che Linux sostituisse la partizione nella quale aveva sede Windows XP. Dopo avere finito l'installazione ho notato con mio rammarico che il boot loader (penso sia LILO) non mi dava la possibilitÓ di scegliere Windows 2000. Dopo tante prove ho trovato un file denominato lilo.conf in Linux, nella cartella /etc, che contiene il seguente listato:
# File generated by DrakX/drakboot
# WARNING: do not forget to run lilo after modifying this file

default="linux"
boot=/dev/hda
map=/boot/map
keytable=/boot/it-latin1.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
image=/boot/vmlinuz
label="linux"
root=/dev/hda1
initrd=/boot/initrd.img
append="acpi=ht resume=/dev/hda5 splash=silent"
vga=788
read-only
image=/boot/vmlinuz
label="linux-nonfb"
root=/dev/hda1
initrd=/boot/initrd.img
append="acpi=ht resume=/dev/hda5"
read-only
image=/boot/vmlinuz
label="failsafe"
root=/dev/hda1
initrd=/boot/initrd.img
append="failsafe acpi=ht resume=/dev/hda5"
read-only

Secondo voi devo aggiungere qualche riga a questo file per rimettere a posto il tutto? Se si cosa?

Aki
03-05-2005, 13:48
Originariamente inviato da pesci74
Ho installato Linux sul mio computer. Prima avevo 2 partizioni nell'Hard disk: la prima C conteneva Windows XP pro, la seconda D Windows 2000. Installando Mandrake Linux con il suo CD ho voluto fare in modo che Linux sostituisse la partizione nella quale aveva sede Windows XP. Dopo avere finito l'installazione ho notato con mio rammarico che il boot loader (penso sia LILO) non mi dava la possibilitÓ di scegliere Windows 2000. Dopo tante prove ho trovato un file denominato lilo.conf in Linux, nella cartella /etc, che contiene il seguente listato:
...
Secondo voi devo aggiungere qualche riga a questo file per rimettere a posto il tutto? Se si cosa?

manca la sezione di avvio di win


other=/dev/<partizione_su_cui_c'Ŕ_win>
label=win2000


ops..

andy caps
03-05-2005, 13:52
other=/dev/hdaxx
label="windows"

dai un fdisk -l per vedere che numerazione da alla partizioni di windows
:bh˛: sperando vada perche probabilmente aveva i file di boot in c:/

pesci74
03-05-2005, 22:33
Grazie mille! Ora provo

Loading