PDA

Visualizza la versione completa : compilare alsa


hallo63
05-05-2005, 20:31
come da istruzioni dal sito
ho scaricato il pacchetto alsadriver
lancio ./configure --with-cards=ca0106 --with-sequencer=yes

ma la risposta finale

checking for kernel version... The file /usr/src/linux/include/linux/version.h does not exist.
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).


se ho capito dovrei avere un collegamento linux al kernel
in usr/src ma io non ce l'ho in mdk 10.1

non so come procedere, se qualcuno mi illumina lo ringrazio

ciao

edriv
05-05-2005, 20:35
beh fai un
ls /usr/src

e se trovi una cartella "linux-*.*.*", fai:
ln -s /usr/src/linux-qual.che. /usr/src/linux

creeeeeeeeeeedo eh! :D

hallo63
05-05-2005, 20:46
da ls /usr/src non ho nessuna risposa

forse devo cercare dove ho la directory del kernel?

ho pensato che in /boot

ma non ne sono sicuro

grazie

side-server
05-05-2005, 20:50
Originariamente inviato da hallo63
da ls /usr/src non ho nessuna risposa

in questo caso devi installare i sorgenti del kernel

:ciauz:

GhePeU
05-05-2005, 21:27
perch stai facendo una cosa del genere? alsa incluso di default nei kernel 2.6

hallo63
05-05-2005, 22:40
la mia audigy sb ls non funziona con alsa fornito da mdk 10.1
(kernel 2.6) pero ho visto che le ultime versioni la supportano.
come dal link

http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Creative+Labs&card=Sound+Blaster+LS.&chip=SB0310%2C+P17&module=ca0106

ho dato

modinfo soundcore

la risposta

[root@localhost maurizio]# modinfo soundcore
filename: /lib/modules/2.6.8.1-10mdksmp/kernel/sound/soundcore.ko.gz
description: Core sound module
author: Alan Cox
license: GPL
alias: char-major-14-*
vermagic: 2.6.8.1-10mdksmp SMP 686 gcc-3.4

quindi se ho capito il kernel non lo devo toccare,
pero' non riesco a compilare


:cry:

GhePeU
05-05-2005, 23:03
aggiorna con rpmdrake tutto il kernel all'ultima versione disponibile, non ne sono sicuro ma pu darsi che sia stata importata una nuova versione di alsa

Loading