PDA

Visualizza la versione completa : lo vorresti eh un boot più veloce?


lnessuno
07-05-2005, 12:05
beh prova initng, un sostituto di sysvinit o quello che c'hai ora.

io l'ho provato su debian, effettivamente è velocissimo anche se quando finisce il boot non mi da la shell (basta schiacciare ctrl-alt-f2), e non parte gdm in automatico (basta aggiungerlo con il comando ng-update add daemon/gdm comunque)


che dire... veramente un ottimo lavoro, merita di essere quantomeno provato. prima di sputtanare il tutto, però, magari mettetelo come scelta secondaria su lilo/grub...:zizi:


http://jw.dyndns.org/initng/

Guglie
07-05-2005, 12:49
da me l'avvio è passato da circa 30 secondi a circa 18 :)
imho il progetto promette davvero bene, e col tempo se molta gente farà testig sarà possibile inserirlo anche nelle distro

:ciauz:

GhePeU
07-05-2005, 12:54
a me interesserebbe di più il software suspend (accendo il computer la mattina e quando non lo uso lo metto in sospensione), ma da quel che leggo nelle faq e in giro non son sicuro sia il caso di provarlo, per ora

Ilmalcom
07-05-2005, 13:04
Grazie della segnalazione, penso ci darò un'occhiata

maiosyet_2
07-05-2005, 14:28
Quando provo a compilarlo fallisce:



cc1: error: unrecognized option `-Wold-style-definition'
make[1]: *** [ngc.o] Error 1
make[1]: Leaving directory `/root/initng-0.0.8/ngcontrol'
make: *** [all] Error 2


Ho GCC 3.5, francamente quel parametro non l'ho mai visto... dite che se provo a levarlo dai source faccio casino? :stordita:

side-server
07-05-2005, 16:27
ma basta dare make e make install? :master:
c'è qualche procedura "speciale" da dover fare?

Guglie
07-05-2005, 16:43
Originariamente inviato da side-server
ma basta dare make e make install? :master:
c'è qualche procedura "speciale" da dover fare?
si, basta quello, c'è scritto nel file readme (http://jw.dyndns.org/initng/index2.php#Readme)
poi bisogna anche aggiungere init=/sbin/initng alle opzioni di lilo

side-server
07-05-2005, 17:33
Originariamente inviato da Guglie
poi bisogna anche aggiungere init=/sbin/initng alle opzioni di lilo

lilo mi riporta:

Unrecognized token "init" at or above line 29 in file '/etc/lilo.conf'

:master:

gigyz
07-05-2005, 17:40
certo è initrd no init

side-server
07-05-2005, 17:42
Originariamente inviato da gigyz
certo è initrd no init

mi pareva strano..

edit: non funziona con initrd=/sbin/initng

mi avvia sempre init e non initng sul pid 1

:master:

Loading