PDA

Visualizza la versione completa : Mplayer e video lenti


fivendra
08-05-2005, 19:52
Ho installato su un P4 con 512mb di ram suse 9.2 e ho installato Mplayer per vedere i divx e i file avi...
Ovviamente ho installato tutti i codec necessari.
Premetto anche che ho attivati dma sull'hd

I video si vedono e si sentono, ma sono a scatti, la cpu sembra andare al 100% e infatti tutto il sistema rallenta tantissimo, anche il mouse va a scatti.
Per far tornare tutto alla normalità devo chiudere mplayer

Non capisco dove possa stare il problema....
Leggendo in giro ho trovato riferimenti al fatto che la mia scheda video (basata su chipset kyro2 con 64mb) non essendo supportata dai kernel 2.6.x (non esistono driver) e dovendo utilizzare i video vesa generici possa essere la causa di questi problemi

Voi che dite?
:ciauz:

andy caps
08-05-2005, 20:26
forse installando il pacchetto precompilato ed ottimizzato per suse potresti guadagnare

prova as avviare mplayer con l'opzione -framedrop

dall'help sembra sia un helper per sistemi lenti

:bhò:

prova ad installare un kernel aggiornato
le kiro hanno i suoi moduli negli ultimi kernel

con apt si trova sia mplayer sia il kernel aggiornato anche se è un dramma installarlo (combina sempre casotti )

fivendra
08-05-2005, 20:31
essendo suse il kernel preferisco non toccarlo.....

per le kyro, ti devo correggere, per i kernel 2.6.x non esistono driver, solo per i vecchi 2.4.x e questo per volere degli sviluppatori del chispet..... (adesso ho il 2.6.8)
quindi qui sono fregato...

per mplayer, vedrò di provare i tuoi suggerimenti....
:ciauz:

andy caps
08-05-2005, 20:42
[root@localhost ~]# modprobe -l | grep kyro
/lib/modules/2.6.11-1.1226_FC4/kernel/drivers/video/kyro/kyrofb.ko
[root@localhost ~]#

adesso sono su fedora 4 e c'è

sulla suse 9.3

/mnt/suse/lib/modules/2.6.8-24-default/kernel/drivers/video/kyro/kyrofb.ko

fivendra
08-05-2005, 20:51
ma porca zozza :D e nessuno mi dice nulla....
nelle pagine di dowload dei driver per linux si diceva chiaramente che non en esistevano per i kernel 2.6.x

tu hai scritto suse 9.3 ma la directory è quella della sus 9.2 perchè la 9.3 ha il kernel 2.6.11

in ogni caso coem faccio a tirargli fuori, perchè nell'elenco dei driver disponibili non mi dava quelli per la kyro....
:ciauz:

andy caps
08-05-2005, 21:01
si quella è la suse 9.2 :D ne ho due momentaneamente di suse

anche da yast dovrebbe darti la possibilita di sceglierli altrimenti prova a mettere mano direttamente in xorg.conf al posto di vesa metti kyrofb dopo averlo caricato con modprobe kyrofb

fivendra
08-05-2005, 21:03
ok domani provo... vediamo un pò cosa succede.....
ma mi sa che devo mettere la 9.3 sul portatile che ha un nvidia....
:ciauz:

andy caps
08-05-2005, 21:11
si merita
a parte un installazione drammatica a causa di qualche pacchetto difettoso sembra davvero fatta bene

niente di nuovo comunque a parte i pacchetti

fivendra
09-05-2005, 10:08
Originariamente inviato da andy caps
si merita
a parte un installazione drammatica a causa di qualche pacchetto difettoso sembra davvero fatta bene

niente di nuovo comunque a parte i pacchetti
si infatti, ma sono legato a mia sorella che non ne vuole sapere di usar elinux e non vuole perdere il suo accont su xp....
ma oggi dovrebbe arrivarle il portatile suo e così non mi rompe più le scatole e faccio quello che voglio.... :D
in mattinta provo la tua soluzione per le kyro
:ciauz:

fivendra
09-05-2005, 14:20
aggiornamento...:
da root ho dato
modprobe kyrofb
ma lo schermo diventa nero....insomma freez....
suggerimenti?
:ciauz:

Loading