PDA

Visualizza la versione completa : audio in simultanea


jaso
10-05-2005, 23:42
ciao a tutti ragazzi

ho una soundmax che funziona perfettamente con i moduli

snd_intel8x0 29760 2
snd_ac97_codec 76024 1 snd_intel8x0

pero non capisco perche quando ascolto la musica con xmms o qualunque altro player non riesco a sentire i suoni di kde oppure di xine ecc..

come devo fare?

FUNCRUSHER
16-05-2005, 10:48
Ho anch'io lo stesso identico problema, solo ke la mia sheda audio integrata sulla sk madre ed utilizza il modulo snd_intel8x0, la mia distro Debian, per l'esattezza ho KANOTIX installata su HD.

thanx!

Guglie
16-05-2005, 11:33
se la vostra scheda audio non supporta il mixing hardware potete provare a usare il software mixing
http://wiki.gentoo-italia.net/index.php/ALSA_soft-mix_aka_dmix

FUNCRUSHER
16-05-2005, 18:41
Grazie dell'aiuto, ho provato a fare come descritto nella pagina puntata dal link ma nulla da fare, il problema persiste.

vortex87
16-05-2005, 18:59
Alsa installato o state usando Oss? :stordita: Questa dovrebbe essere la principale differenza tra i due :fagiano:

FUNCRUSHER
17-05-2005, 00:05
si alsa installato,

ho seguito le istruzioni riportate su http://wiki.gentoo-italia.net/index.php/ALSA_soft-mix_aka_dmix

e dopo aver creato il file /etc/asound.conf l'ho anche riavviato col comando:

# /etc/init.d/alsa restart

ho anche cambiato nel centro di controllo di KDE il server sonoro da oss a alsa, ho apportato questa modifica anche a xmms e amsn, ma non ho ottenuto alcun risultato, cio l'audio funziona, ma sempre solo per un programma per volta.

Guglie
17-05-2005, 16:42
Originariamente inviato da FUNCRUSHER
si alsa installato,

ho seguito le istruzioni riportate su http://wiki.gentoo-italia.net/index.php/ALSA_soft-mix_aka_dmix

e dopo aver creato il file /etc/asound.conf l'ho anche riavviato col comando:

# /etc/init.d/alsa restart

ho anche cambiato nel centro di controllo di KDE il server sonoro da oss a alsa, ho apportato questa modifica anche a xmms e amsn, ma non ho ottenuto alcun risultato, cio l'audio funziona, ma sempre solo per un programma per volta.
occhio che quella guida fatta specificamente per gentoo, che specialmente negli init un po' diversa da debian

io per provare se funziona lancerei diversi aplay piuttosto che amsn xmms e kde

FUNCRUSHER
17-05-2005, 18:49
io per provare se funziona lancerei diversi aplay piuttosto che amsn xmms e kde

ho provato a lanciare piu' istanze di aplay contemporaneamente e funziona!!!

Ora pero' come faccio a farlo funzionare nel mio sistema?

Come ho gi detto precedentemente ho impostato xmms e amsn ad usare ALSA come server sonoro, ma quando tentano di accedere contemporaneamente al server uno dei tue lo trova occupato.

Loading