PDA

Visualizza la versione completa : Problema logout shutdown e reboot a schermo nero


unomichisiada
28-05-2005, 19:47
Salve,dopo molte peripezie sono finalmente riuscito a far funzionare l'accelerazione 3d della mia scheda video su linux.Ora per ho un'altro problema che non so se dipenda da nuovo driver perch non saprei dire se sorto in corrispondenza della sua installazione o no.
Quando faccio un termina sessione o spengo il pc con halt o lo riavvio con reboot lo schermo si annerisce completamente ed il computer si spegne o si riavvia o termina la sessione di gnome/kde ma senza faermi vedere nessuno dei consueti messaggi.La cosa pi fastidiosa quando faccio termina sessione,il windowmanager termina e mi riporta al login ma sempre a schermo nero.Non saprei proprio dove metter le mani per risolvere il problema,ho provato a frugare l'xorg.conf ma senza risultati.A qualcuno maicapitato lo stesso problema?Se pu essere utile uso Fedora Core 3,ed ho una scheda ATI Mobility Radeon 9700 (che come ho gi detto ora funziona perfettamente per).

unomichisiada
28-05-2005, 20:03
Cavolo ma che titolo mi ha messo? :confused: E' stato un errore il titolo originale era "Problema logout shutdown e reboot a schermo nero"

andy caps
28-05-2005, 20:06
e il framebuffer consolle che da questo problema

disabilitandolo non lo fa

con mandrake ad esempio basta togliere splash=silent
da lilo.conf

unomichisiada
29-05-2005, 12:04
Originariamente inviato da andy caps
e il framebuffer consolle che da questo problema

disabilitandolo non lo fa

con mandrake ad esempio basta togliere splash=silent
da lilo.conf
Grazie per la risposta.Ho fedora ed il bootloader grub,non che mi sai dire dove devo samnettare?Sempre sui file di configurazione del bootloader o devo cambiare qualcosa nell'xorg.conf?

andy caps
29-05-2005, 12:47
si nelle opzioni del bootloader

:bh: prova ad aggiungere una nuova voce copiando ed incollando che non contenga rhgb quiet in /boot/grub/grub.conf

con grub sempre un dilemma

unomichisiada
29-05-2005, 13:03
Originariamente inviato da andy caps
si nelle opzioni del bootloader

:bh: prova ad aggiungere una nuova voce copiando ed incollando che non contenga rhgb quiet in /boot/grub/grub.conf

con grub sempre un dilemma
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,5)
# kernel /boot/vmlinuz-version ro root=/dev/hdc6
# initrd /boot/initrd-version.img
#boot=/dev/hdc
default=0
timeout=10
splashimage=(hd0,5)/boot/grub/splash.xpm.gz
hiddenmenu
title WinXP
rootnoverify (hd0,1)
chainloader +1
title Fedora Core-up (2.6.9-1.667)
root (hd0,5)
kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-1.667.img


Questo il mio grub.conf,sinceramente non mi sembra si possa fare nessuna modifica sensata.Non che hai qualche consiglio su una possibile modifica che la provo al volo?

unomichisiada
29-05-2005, 13:06
Ah no apsetta rgbquiet non l'avevo visto.Tu dici di levare quello?E se poi non mi parte pi linux che faccio?Non ho neanche il drive floppy er fare un disco di avvio

andy caps
29-05-2005, 13:11
aggiungi una nuova sezione copiando ed incollando quella sopra poi cambiali il label

non dovesti avere problemi

:madai!?: il rischio comunque c' sempre
con lilo saresti piu tranquillo

unomichisiada
29-05-2005, 13:22
Originariamente inviato da andy caps
aggiungi una nuova sezione copiando ed incollando quella sopra poi cambiali il label

non dovesti avere problemi

:madai!?: il rischio comunque c' sempre
con lilo saresti piu tranquillo
Si lo so ma con fedora quello passa il convento purtroppo,non so se si possa installare lilo e come fare (sono abbastanza inesperto ancora)
Allora io ho provato ad inserire una nuova voce con tutto ci che c'era dopo LABEL cancellato ma l'unico risultato stato un messaggio all'avvio sul logger disabilitato e nessun miglioramento sul fronte del mio problema.Come va modificata la LABEL

andy caps
29-05-2005, 14:06
prova al posto di rhgb quiet a scriverci nofb

il label sarebbe il title

Loading