PDA

Visualizza la versione completa : httpd make install prefix


discepolo
01-06-2005, 14:48
Ciao

con la bibbia sotto il braccio, mi apprestavo a installare a manina apache 2.0.59

feci
mkdir /urs/local/apache
poi scompattari il file .tar.gz
nella mia home
poi mi diressi nella dir creata e diedi
./configure --prefix=/usr/local/apache
dopo divenni un supereroe
e diedi
make
fin qui tutto ok

poi seguendo e prendendo spunto dalla bibbia di apache emisi il seguente comando :
make install --prefix=/usr/local/apache
mi disse non ci sono opzioni per questa voce!! se ricordo bene!


Ciao :ciauz:

side-server
01-06-2005, 16:35
1) Apache 2.0.59 non esiste.
2) quando dai make install non serve specificare --prefix, l'hai giÓ impostato nel configure.

:ciauz:

discepolo
01-06-2005, 18:14
Originariamente inviato da side-server
1) Apache 2.0.59 non esiste.

vero Ŕ la 54!!:stordita:

Originariamente inviato da side-server
2) quando dai make install non serve specificare --prefix, l'hai giÓ impostato nel configure.

:ciauz:

infatti
ho dato make install senza prefix e mi ritro come da bibbia la dir /usr/local/apache

beddo f¨!!

:yuppi: :ciauz:

discepolo
02-06-2005, 14:04
CuriositÓ

se non l avessi messo nel config

lo potevo mettere nel comando make install ?! :stordita:

:ciauz:

side-server
02-06-2005, 14:45
Originariamente inviato da discepolo
CuriositÓ

se non l avessi messo nel config

lo potevo mettere nel comando make install ?! :stordita:

:ciauz:

in teoria no xchŔ se nel configure non specifichi --prefix automaticamente lo installa in /usr

:ciauz:

discepolo
01-07-2005, 14:32
faccio riemergere sta discussione!! :D

problemino nella configurazione!

posto il httpd.conf:

<VirtualHost 195.128.235.130>
ServerAdmin pietrobolfo@yahoo.it
DocumentRoot /wwww/bolfo/
ServerName www.bolfo.it
<Directory "/wwww/bolfo/">
Options Indexes FollowSymLinks MultiViews
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

quando do il comando il ./apachectl start

ottengo:

root@satana1977:/usr/local/apache/bin # ./apachectl start
Warning: DocumentRoot [/wwww/bolfo/] does not exist
no listening sockets available, shutting down
Unable to open logs
root@satana1977:/usr/local/apache/bin #


:master:
il warning non lo capisco perchŔ la dir l'ho creata!!
il resto ihmo, boh!!

:dh˛:

son troppo :fagiano: :stordita: :P


:ciauz:

discepolo
01-07-2005, 14:36
Originariamente inviato da discepolo

DocumentRoot /wwww/bolfo/
ServerName www.bolfo.it
<Directory "/wwww/bolfo/">


rettifica ho messo un w di troppo !!

dopo la modifica che ho fatto ottengo :

root@satana1977:/usr/local/apache/bin # ./apachectl start
no listening sockets available, shutting down
Unable to open logs
root@satana1977:/usr/local/apache/bin #


devo smettere di farmi le cannucce!!

:biifu:

pannikeos
02-07-2005, 00:58
<VirtualHost 195.128.235.130>
ServerAdmin pietrobolfo@yahoo.it
DocumentRoot /wwww/bolfo/
ServerName www.bolfo.it
<Directory "/wwww/bolfo/">
Options Indexes FollowSymLinks MultiViews
Order allow,deny
Allow from all
</Directory>
</VirtualHost>


mhm .. ma i virtual hosts li hai abilitati ?

c'Ŕ una stringa prima che te li identifica, adesso nn ricordo il nome del set. ravana :)
:ciauz:

discepolo
02-07-2005, 03:27
Originariamente inviato da pannikeos
mhm .. ma i virtual hosts li hai abilitati ?


:master:

come abilitati ? :master:

pannikeos
02-07-2005, 15:04
direttiva: NameVirtualHost

se no ravana nella manualistica di apache

:ciauz:

Loading