PDA

Visualizza la versione completa : squid, limitare dimensione del file


9issara
08-06-2005, 17:28
:) ciao tutti vorrei sapere come si fa limitare il dimensione del file in upload??
es. i client non possono allegare un file maggiore di 5 Mb, grazie tutti

naig
08-06-2005, 22:18
Forse devi impostare questo parametro (cerca in squid.conf) mette dei vincoli alla dimensione del corpo della risposta HTTP

reply_body_max_size 0 allow all

al posto di 0 metti la dimensione massima in byte (!)
e al posto di allow metti deny (non sono sicuro su questa impostazione, eventualmente fai delle prove)


Cmq ti posto la parte di squid.conf in cui si fa riferimento con i commenti. Tieni presente che l'impostazione predefinita 0 allow all non pone alcun limite.
Se poi vuoi fare una cosa pił complessa puoi impostare una policy differenziata specificando le acl ad hoc

# TAG: reply_body_max_size bytes allow|deny acl acl...
# This option specifies the maximum size of a reply body in bytes.
# It can be used to prevent users from downloading very large files,
# such as MP3's and movies. When the reply headers are recieved,
# the reply_body_max_size lines are processed, and the first line with
# a result of "allow" is used as the maximum body size for this reply.
# This size is checked twice. First when we get the reply headers,
# we check the content-length value. If the content length value exists
# and is larger than the allowed size, the request is denied and the
# user receives an error message that says "the request or reply
# is too large." If there is no content-length, and the reply
# size exceeds this limit, the client's connection is just closed
# and they will receive a partial reply.
#
# WARNING: downstream caches probably can not detect a partial reply
# if there is no content-length header, so they will cache
# partial responses and give them out as hits. You should NOT
# use this option if you have downstream caches.
#
# If you set this parameter to zero (the default), there will be
# no limit imposed.
#
#Default:
# reply_body_max_size 0 allow all

Loading