PDA

Visualizza la versione completa : apache, permessi su file su partizione "windows"...


yellowduck
10-06-2005, 01:15
Ho installato correttamente Apache su una Mandrake 10.1

Ho cambiato la DocumentRoot settandola sulla partizione FAT32 (che uso normalmente in win2k, in linux /mnt/win_f) che contiene tutti i miei siti.

Quando tento di accedere alle dir e ai file, per, Apache mi dice che non ho il permesso di accedere a quei file (anche semplicemente http://localhost).

Devo settare i chmod su quelle dir? Una a una? O c' un comando per settare il chmod su tutta la partizione? Una volta settati i chmod, i file saranno normalmente accessibili quando accedo alla partizione da windows?

Scusate le domande da newbie (del resto lo sono! :stordita: ), ma non vorrei fare danni irreparabili sul mio lavoro...

_YD

l.golinelli
10-06-2005, 09:12
Non si cambiano i permessi sul FAT32

Montalo con l'ozione umask=0000

yellowduck
10-06-2005, 14:57
ehm... grazie, ma... come si fa?

_YD

l.golinelli
10-06-2005, 15:00
modifichi il file /etc/fstab inserendo la riga per il filesystem che devi montare e ci metti quell'opzione...

http://a2.swlibero.org/a2122.html#almlindex8467

yellowduck
10-06-2005, 16:02
Fatto, ma con umask=0000 continua a darmi "Forbidden"... :dh:

(grazie del link, cmq... molto prezioso!)

_YD

yellowduck
11-06-2005, 00:55
nessuna altra idea? :dh:

_YD

l.golinelli
11-06-2005, 11:57
Mettere la document root sul filesystem linux non una cattiva idea...

Cmq prova con un utente che non sia root ad accedere al filesystem fat32 e vedi se ti fa accedere...

Kandalf
11-06-2005, 12:51
ma nn che hai fra le Options di apache -Indexes?

yellowduck
11-06-2005, 16:03
Originariamente inviato da l.golinelli
Mettere la document root sul filesystem linux non una cattiva idea...
Il principio che vorrei lavorare sugli stessi file sia da Windows che da Linux... x questo ho formattato la partizione di lavoro in FAT32, proprio xch potesse essere la DocumentRoot di Apache_under_win e di Apache_under_GNU :) Altrimenti mi toccherebbe (ogni volta che cambio SO) copiarmi tutti i file su un supporto esterno... addio praticit!



Originariamente inviato da l.golinelli
Cmq prova con un utente che non sia root ad accedere al filesystem fat32 e vedi se ti fa accedere...
S, riesco a scrivere file nuovi e anche a modificare file gi scritti. Il problema era che avevo lasciato "deny from all"... :stordita:

Ora mi resta solo il problema che non mi crea gli indici delle directories... se digito http://localhost continua a darmi forbidden...

_YD

Kandalf
11-06-2005, 22:17
hai provato controllare le Options!?

Loading