PDA

Visualizza la versione completa : SimCity 3000 per linux


Fabio3D
10-06-2005, 09:47
Buongiorno, ireccomi a rompere le scatole!! :)

Allora, ho Mandrake linux 10.2 (mandriva 2005 le) su un portatile acer con p4 a 3.2 ghz e radeon mobility 9700.

Ho voluto provare a mettere SimCity 3000 per Linux, solo che qualcosa non funge :incupito:

Installazioen completata con successo, solo che quando tento di avviaare il file eseguibile non parte e se tento da riga di comando mi restituisce questo bell'errore alla windows (ovvero incomprensibile).

qualcuno sa darmi uan dritta?

grazie in anticipo

Leonardo Arte
10-06-2005, 12:16
Scaricati la patch che risolve quel problema dal sito della casa madre del prodotto ;)

Anche io ce l'avevo ed era questione di fare l'upgrade ;)

BUona giornata

Fabio3D
10-06-2005, 13:35
Ti ringrazio mi reco subito a vedere... se avessi difficoltà sarò di nuovo qui a rompere :yuppi:


ciao e grazie ancora

Fabio3D
10-06-2005, 14:02
Infatti eccomi qui.. :dhò:

Allora, per prima cosa ho scaricato il file "loki_update-full-1.0.13-x86.run" per utilizzare a funzione di update automatizzato.. Risultato vedi allegato.

Poi ho scaricato l'aggiornamento denominato "sc3u-2.0a-x86.run" ed il risutato è il medesimo.

Anticipo che i file li ho avviati con il doppio click del mouse.

(mi scuso per l'indecenza dell'immagine ma the gimp è ancora un po astruso per me in fatto di ottimizazione)

Neon87
10-06-2005, 14:08
devi aprire un terminale...
e scrivere

chmod +x nomefile.run
./nomefile.run

e leggere quello che ti dice...

Fabio3D
10-06-2005, 14:26
Fatto.

Ciò che mi viene mostrato è:

Verifiying archive integrity...OK
Uncompressing SimCity 3000 Unlimited 2.0a Updatetrap: usage: trap [-lp] [arg signal_spec ...]

Ed ora cosa dovrei fare? Abbi pazienza ma sono proprio neofita con linux...

Meskalamdug
10-06-2005, 19:16
Originariamente inviato da Fabio3D
Fatto.

Ciò che mi viene mostrato è:

Verifiying archive integrity...OK
Uncompressing SimCity 3000 Unlimited 2.0a Updatetrap: usage: trap [-lp] [arg signal_spec ...]

Ed ora cosa dovrei fare? Abbi pazienza ma sono proprio neofita con linux...
la soluzione e' semplice
da console
bash nomefile.run
:)

Fabio3D
10-06-2005, 21:51
Grazie mille..

nonostante tutto non sono riuscito nelmio intento, infatti il file si avvia..

Ma poi non fa untubo :( ù

Grazie lo stesso per la pazienza.

Buona serata

Neon87
10-06-2005, 23:34
Originariamente inviato da Fabio3D
Grazie mille..

nonostante tutto non sono riuscito nelmio intento, infatti il file si avvia..

Ma poi non fa untubo :( ù

Grazie lo stesso per la pazienza.

Buona serata

in che senso si avvia?
fa come prima

Verifiying archive integrity...OK
Uncompressing SimCity 3000 Unlimited 2.0a Updatetrap: usage: trap [-lp] [arg signal_spec ...]

e basta?

Fabio3D
11-06-2005, 20:03
Si esatto
da quel messaggio di risposta e non fa altro, inutile dire che l'aggiornamento non è stato effettuato poichè il gioco non parte.

Ho tentato anche di utilizzare l'utilità di aggiornamento automatico della Loki e funziona tutto se non che sui server su cui cerca non trova la gpg signature, di conseguenza non effettua l'aggiornamento purtroppo...

Loading