PDA

Visualizza la versione completa : [Debian] Spegnimento automatico


S[p]|llo`
10-06-2005, 17:22
Tempo fa ho aperto un thread simile ma per Mepis, tra l'altro non sono riuscito a risolvere, cmq ho installato il kernel 2.6.11-1 convito che passando dal 2.4 mi avrebbe gestito lo spegnimento automatico... invece devo cmq spegnerlo a mano.
Detto che Ubuntu Hoary non mi da questo problema, cio una volta che ha finito di "smontare" il tutto si spegne automaticamente, cosa devo fare... modificare qualcosa nel kernel... oppure... mah :fagiano: :fagiano:

stai_tranquillo
10-06-2005, 17:29
laptop, desktop.. che macchina ?

acpi lo carichi?

acpid parte?

S[p]|llo`
10-06-2005, 20:38
Originariamente inviato da stai_tranquillo
laptop, desktop.. che macchina ?

acpi lo carichi?

acpid parte?
E' un desk, fra le opzioni di boot ho messo "acpi=on apm=off", come prima riga di caricamento ho come messaggio: "ACPI unable to load RDSP (ma questo credo sia relativo, visto che me lo fa anche con Ubuntu)". Per quanto riguarda acpid, se d modinfo ho un messaggio negativo (ma non so se quello che vuoi sapere :fagiano: )

S[p]|llo`
10-06-2005, 20:41
Non so se pu essere utile, posto la parte relativa al boot di Debian
title Debian Sarge 3.1 (2.6.11-1-386)
root (hd0,8)
kernel /boot/vmlinuz-2.6.11-1-386 root=/dev/hda9 ro
quiet splash=verbose vga=791 apm=off acpi=on
initrd /boot/initrd.img-2.6.11-1-386
savedefault
boot

francofait
10-06-2005, 22:12
Originariamente inviato da S[p]|llo`
Non so se pu essere utile, posto la parte relativa al boot di Debian
title Debian Sarge 3.1 (2.6.11-1-386)
root (hd0,8)
kernel /boot/vmlinuz-2.6.11-1-386 root=/dev/hda9 ro
quiet splash=verbose vga=791 apm=off acpi=on
initrd /boot/initrd.img-2.6.11-1-386
savedefault
boot

alle opzioni da passare al kernel aggiungi: apm=off acpi=on
noapic nolapic

S[p]|llo`
11-06-2005, 20:39
Originariamente inviato da francofait
alle opzioni da passare al kernel aggiungi: apm=off acpi=on
noapic nolapic
Ho aggiunto quello che mi hai detto
title Debian Sarge 3.1 (2.6.11-1-386)
root (hd0,8)
kernel /boot/vmlinuz-2.6.11-1-386 root=/dev/hda9 ro
apm=off acpi=on noapic nolapic quiet splash=verbose vga=791
initrd /boot/initrd.img-2.6.11-1-386
savedefault
boot
Ma purtroppo non ho risolto il problema, per perch su ubuntu lo spegnimento automatico funziona? Da Grub gli passo anche meno comandi....
title Ubuntu Hoary 5.04
root (hd0,9)
kernel /boot/vmlinuz-2.6.10-4-386 root=/dev/sda10 ro
quiet splash=verbose vga=791
initrd /boot/initrd.img-2.6.10-4-386
savedefault
boot

francofait
11-06-2005, 23:17
provato ad invertire mettendo :
apm=on acpi=off noapic

????

S[p]|llo`
12-06-2005, 10:45
Originariamente inviato da francofait
provato ad invertire mettendo :
apm=on acpi=off noapic

????
Fatto, ma non ho risolto niente.
A questo punto non potrei confrontare la configurazione della Ubuntu con quella di Debian, che ne so, il kernel, moduli caricati al boot.... :bh: :bh: Perch cmq da una parte funziona e dall'altra no, quindi c' qualcosa che con un Ubuntu viene caricato (o eseguito) e con Debian no (evidentemente) :master: :fagiano:

S[p]|llo`
13-06-2005, 12:49
Uppettino

S[p]|llo`
21-06-2005, 13:14
Tutto ok :zizi: :zizi:
Non avevo installato tutto quello che riguardava "acpi" e tutto il resto :fagiano: :fagiano:
grazie per l'interessamento :ciauz:

Loading