PDA

Visualizza la versione completa : sda sparito


nik600
11-06-2005, 19:30
ciao

non capisco perch sulla mia slack 10.1 non esiste piu sda..sdb...ecc ecc

la cosa strana che io collego la chiave usb e vedo questo da dmesg:



scsi0 : SCSI emulation for USB Mass Storage devices
Vendor: Sony Model: Sony DSC Rev: 4.10
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sda: 31680 512-byte hdwr sectors (16 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
sda: sda1
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0
USB Mass Storage device found at 3



ma sotto /dev/s...trovo solo:



root@criminal:/home/nik600$ ls /dev/s*
/dev/sequencer /dev/sequencer2 /dev/stderr /dev/stdin /dev/stdout

/dev/shm:

/dev/snd:
controlC0 pcmC0D0c pcmC0D0p pcmC0D1c pcmC0D2c pcmC0D3c pcmC0D4p seq timer

/dev/sound:
adsp audio dsp mixer sequencer sequencer2



:master: :master:

Trotto@81
12-06-2005, 15:06
Se usi il kernel 2.4.xx allora vai dentro /dev/ e con i privilegi di root lancia ./MAKEDEV sda1 e il problema risolto. :)

nik600
12-06-2005, 15:58
ho il kernel 2.6.8.1

Trotto@81
12-06-2005, 16:10
La questione diversa, in questo caso udev che si occupa alla creazione dinamica dei device in /dev.
Io non conosco bene udev perch sono rimasto al 2.4 quindi informati sul forum o in giro per la rete.
Cmq i file di conf di udev stanno sotto /etc/udev, almeno sotto slack cos.

Meskalamdug
13-06-2005, 02:23
Devi solo riavviare udev,con sda "acceso",io faccio cosi' col disco esterno :)

untamed
13-06-2005, 11:08
In che senso con sda "acceso"? (la cosa interessa anche me, ho lo stesso problema) :fagiano:

Meskalamdug
13-06-2005, 13:18
Stavo parlando di un disco esterno
:fagiano:

untamed
13-06-2005, 13:40
Pero` con la chiavetta e` diverso. Bisogna smanettare con /etc/udev quindi? Io ho anche provato a creare /dev/sda con mknod ma al ariavvio scompare.

stai_tranquillo
13-06-2005, 13:47
leggete bene :D



Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0


non sparito nulla, semplicemente la tua chiavetta si chiama sg0

:)

untamed
13-06-2005, 13:55
Pero` dal post di Nik600, si vede che /dev/sg0 non esiste. Anche io avevo cercato sg0 ma non c'e`... :dh:

Loading