PDA

Visualizza la versione completa : [scheda video Trident] dubbi su moduli


lecora_marco
15-06-2005, 14:33
Ho dei dubbi per quanto riguarda X11 e i moduli della scheda video.

Il fatto che in xorgcfg mi viene elencata anche la mia scheda video significa che ho i moduli adatti ... ? perchè allora se do lsmod non compare il modulo relativo alla scheda video ?

ho una trident cyberbladei1 e gentoo 2005 con kernel 2.6

grazie mille

lecora_marco
15-06-2005, 20:48
dubbio sciolto ... era solo una piccola "sbandatina"
ps perchè non riesco ad attivare il direct rendering?

:dhò:

vorrei per lo meno fare una partitella a doom o quake ... :(

andy caps
15-06-2005, 20:50
il modulo lo devi caricare se vuoi che la scheda funzioni correttamente

dai un

modprobe -l | grep trident

e guarda che ci sia il modulo prima di tutto
poi scrivilo in /etc/module.autoload.d/kernelxx

poi al'avvio lo carica se c'è

lecora_marco
15-06-2005, 22:18
ho dato modprobe -l | grep trident

e mi da


/lib/modules/2.6.11-gentoo-r3/kernel/sound/pci/trident/snd-trident.ko
/lib/modules/2.6.11-gentoo-r3/kernel/sound/pci/trident/snd-trident-synth.


non vi è traccia della scheda video :-(

se do lspci mi da invece ...



0000:00:00.0 Host bridge: ALi Corporation M1621 (rev 01)
0000:00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller (rev 01)
0000:00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 01)
0000:00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
0000:00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c3)
0000:00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
0000:00:13.0 CardBus bridge: O2 Micro, Inc. OZ6812 CardBus Controller (rev 05)
0000:00:14.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1 (rev 5d)


cosa è che non va?
dove lo prendo il modulo ?

andy caps
15-06-2005, 22:22
lo devi inserire nel kernel ricompiladolo

magari come modulo dalla sezione graphics

lecora_marco
16-06-2005, 12:40
ho ricompilato il kernerl con il supporto trident nella sezione graphics e ora mi da



bash-2.05b# modprobe -l| grep trident
/lib/modules/2.6.11-gentoo-r3/kernel/sound/pci/trident/snd-trident.ko
/lib/modules/2.6.11-gentoo-r3/kernel/sound/pci/trident/snd-trident-synth.ko
/lib/modules/2.6.11-gentoo-r3/kernel/drivers/video/tridentfb.ko


ma del rendering niente ancora ..cosa devo fare ?

andy caps
16-06-2005, 14:30
guarda la guida per il rendering sul forum d gentoo
controlla le cose da installare

http://www.gentoo.org/doc/it/dri-howto.xml

marcopss
06-04-2006, 15:16
Ciao, scusa se a distanza di anni mi aggancio a questa discussione, ma vorrei sapere se hai risolto il problema dell' abilitazione del DRI per la Cyberblade\i1. Lo vorrei sapere percè ho anche io lo stesso problema sulla SUSE 10.0. In particolare, pare che nel kernel sia stato compilato il supporto "tridentfb" (come modulo esterno), ma quando provo a caricarlo con mprode da dmesg vedo che l' operazione è andata in errore.

Se te o qualcun' altro mi rispondesse mi farebbe un grande piacere.
Ciao e grazie a tutti.

Loading