PDA

Visualizza la versione completa : Problema temporale e libcrypto


simulator
16-06-2005, 16:36
Oggi causa temporale si distrutto il server. Grazie al cd di installazione ho ripristinato il sistema e il server web e mysql...il samba per mi d un errore con libcrypto.so.2.....ho provato a reinstallare da tar.gz openssl e da rpm ma nessun risultato....qualcuno sa come si puo risolvere?

simulator
16-06-2005, 19:57
il problema esatto "error while loading shared libraries_libcrypto.so2:cannot open shared object:no such file or directory.
Aiutooooooo :oVVoVe: :oVVoVe: :oVVoVe: :oVVoVe: :oVVoVe: :oVVoVe:

andy caps
16-06-2005, 21:42
ad occhio e croce io reinstallarei

andy:~# apt-cache search libcrypto
libcrypto++-dev - Crypto++ library - header files and validation executable
libcrypto++-utils - Crypto++ library - utilities and data files
libcrypto++5.2 - Crypto++ library
libcryptokit-ocaml - cryptographic algorithm library for OCaml - runtime
libcryptokit-ocaml-dev - cryptographic algorithm library for OCaml - development
libssl0.9.6 - SSL shared libraries (old version)
libssl0.9.7 - SSL shared libraries
andy:~#


o darei un locate libcrypto.so2

e se il caso rilinkarle in /usr/lib dalla posizione in cui si trovano

simulator
17-06-2005, 00:05
e come si fa? :dh: :dh: :dh: :dh:

andy caps
17-06-2005, 00:20
cosa ?

per i pacchetti si installano per lincare la libreria se ad esempio un link che punta a

/usr/lib/libcrypto.so2++x2
si da il comando
cd /usr/lib
poi ln -s /libcrypto.so2++x2 libcrypto.so2

se fossero in /usr/local/lib libcrypto.so2

si da

cd /usr/lib

ln -s /usr/local/lib/libcrypto.so2

simulator
17-06-2005, 00:37
ho fatto locate etc e mi da lib/libcrypto.so.2, il problema che sto file nn c'....dovendo rilinkarli nn so da dove prenderli...ho fatto un find / -name libcrypto.so.2 ma nn mi da risultato

andy caps
17-06-2005, 00:42
dai un ls /lib | grep libcrypto
ls /usr/lib | grep libcrypto

guarda se vedi qualcosa

su debian ad esempio
andy:~# locate libcrypto
/usr/lib/i486/libcrypto.so.0.9.7
/usr/lib/i586/libcrypto.so.0.9.7
/usr/lib/i686/cmov/libcrypto.so.0.9.7
/usr/lib/libcrypto.a
/usr/lib/libcrypto_pic.a
/usr/lib/libcrypto.so
/usr/lib/libcrypto.so.0.9.7
andy:~# ls -ls /usr/lib/libcrypto.so
0 lrwxrwxrwx 1 root root 18 2005-06-11 00:50 /usr/lib/libcrypto.so -> libcrypto.so.0.9.7

e come vedi /usr/lib/libcrypto.so un link che punta a /usr/lib/libcrypto.so.0.9.7

simulator
17-06-2005, 08:45
mi esce scritto libcrypto.so.0.9.7a
libcrypto.so.4

Non mi esce scritto libcypto.so.2......che fo?

simulator
17-06-2005, 08:47
:dh: :oVVoVe: :oVVoVe: :incupito: :incupito: in usr/lib mi esce libcrypto.a
libcrypto.so.... :dh:

simulator
17-06-2005, 08:49
e il link puntoa a libcrypto.so.0.9.7a.....
come vado avanti?scusa ma la prima volta che ho problemi del genere...

Loading