PDA

Visualizza la versione completa : errore configurazione scheda di rete


nik600
02-07-2005, 14:41
ciao

ho una scheda di rete PCI della zyxel, l'ho inserita nello slot PCI di una macchina con installata una slackware 10.1

ho avviato la macchina, hjo lanciato netconfig e ho impostato host,dominio,ip,subnet, gateway e dns

infatti se faccio un

#ifconfig eth0

ottengo tutti i dati corretti, il problema che se faccio
#ifconfig eth0 up

mi dice: SIOCSIFLAGS: Devicer or Resource busy

ho provato anche a riavviare, e anche a cambiare slot PCI...ma nada

la scheda cmq vista correttamente! mi da sia lil mac address che ip e subnet, cosa pu essere?

Whitecrowsrain
02-07-2005, 14:57
Devicer or Resource busy

io non uso la tua stessa distribuzione, ma quando c' un messaggio del genere vuol dire che la risorsa occupata, che la sta usando qualche altro processo!!!

vedi tu :ciauz:

andy caps
02-07-2005, 15:09
dai un dmesg | grep eth e controlla se ci sono problemi controlla che il modulo della scheda sia caricato correttamente

a volte apic che crea pasticci
con mandriva dovevo fare l'append a lilo con noapic per usarla

nik600
02-07-2005, 18:53
mela vede come realtek! anche se una zyxel!

che sia per quello???

gigyz
02-07-2005, 19:32
realtek fa chipset, zyxel no quindi ...

andy caps
02-07-2005, 19:52
carica 8139too con modprobe

poi ritenta

nik600
03-07-2005, 16:46
ciao

anche con modprobe 8139too fa la stessa cosa...

lo ho messo anche in /etc/rc.d/rc.modules (/sbin/modprobe 8139too) e ho riavviato ma senza risultati...

anche se lancio lo script /etc/rc.d/rc.init1

ottengo l'errore:
SIOCSIFLAGS: Devicer or Resource busy


sia che lo script venga lanciato da me a mano che nel caso in cui viene automaticamente lanciato al reboot...che faccio?

nik600
03-07-2005, 16:48
questo il risultato di

dmesg | grep eth



eth0: RealTek RTL8139 at 0xd0aea000, 00:a0:c5:b2:6e:b3, IRQ 0
eth0: Identified 8139 chip type 'RTL-8100B/8139D'


ifconfig eth0



eth0 Link encap:Ethernet HWaddr 00:A0:C5:B2:6E:B3
inet addr:192.168.100.99 Bcast:192.168.100.255 Mask:255.255.255.0
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Base address:0xa000



ifconfig eth0 up




SIOCSIFLAGS: Devicer or Resource busy

cacao74
03-07-2005, 17:17
Caro nik600...
se tu dici ad una persona di alzarsi, quando gia in piedi, secondo te, non ti risponde a modo ? :zizi:

Quando viene utilizzato 'ifconfig' per configurare una scheda di rete, viene implicitamente attivata tale scheda. In pratica, quello che il sistema ti dice corretto, visto che la tua NIC gia attiva.

Un estratto dalla pagina di manuale di 'ifconfig':


...
OPTIONS
up This flag causes the interface to be activated. It is implic-
itly specified if an address is assigned to the interface.


Ma sono tanto brutte 'ste pagine di manuale?
:zizi:

ciao

nik600
03-07-2005, 17:50
ciao

nulla da dire sulle pagine di manuale, sicuramente avrai ragione

cmq su tutte le macchine in cui ho lavorato dando piu volte

ifconfig eth0 up

anche se l'interfaccia era gia su non ho mai ricevuto errori di questo tipo, come ho gia detto la scheda si cunfigura ma non funziona

Loading