PDA

Visualizza la versione completa : Problema di condivisione internet con windows XP professional (+Service Pack 2)


masterix21
02-07-2005, 16:50
Sto uscendo pazzo per la configurazione di una rete tra due computer, più precisamente per fargli condividere la connessione ad internet.

Premesso che ho assegnato gli ip su entrambi i pc e che il ping funziona (entrambe le macchine rispondono), non riesco a condividere la connessione Internet.

Sul pc principale, cioè quello con il modem ethernet collegato (ho Alice ADSL Flat con modem ETH) il risultato di ipconfig /all è il seguente:




C:\Documents and Settings\root>ipconfig /all

Configurazione IP di Windows

Nome host . . . . . . . . . . . . . . : DOOKIE-DESKTOP
Suffisso DNS primario . . . . . . . :
Tipo nodo . . . . . . . . . : Sconosciuto
Routing IP abilitato. . . . . . . . . : No
Proxy WINS abilitato . . . . . . . . : No

Scheda Ethernet Connessione alla rete locale (LAN) 2:

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : NVIDIA nForce MCP Networking Adapter
Indirizzo fisico. . . . . . . . . . . : 00-0C-6E-9B-A7-AB
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 192.168.100.10
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Indirizzo IP. . . . . . . . . . . . . : fe80::20c:6eff:fe9b:a7ab%15
Gateway predefinito . . . . . . . . . : 192.168.100.1
Server DNS . . . . . . . . . . . . . : 192.168.100.1
fec0:0:0:ffff::1%3
fec0:0:0:ffff::2%3
fec0:0:0:ffff::3%3

Scheda Ethernet Connessione alla rete locale (LAN) 3:

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : 3Com 3C920B-EMB Integrated Fast Ethernet Controller
Indirizzo fisico. . . . . . . . . . . : 00-26-54-11-C1-19
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 192.168.0.1
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Indirizzo IP. . . . . . . . . . . . . : 2002:5237:7289:10:b87f:37c1:389c:74b9
Indirizzo IP. . . . . . . . . . . . . : 2002:5237:7289:10:226:54ff:fe11:c119
Indirizzo IP. . . . . . . . . . . . . : fec0::10:226:54ff:fe11:c119%2
Indirizzo IP. . . . . . . . . . . . . : fe80::226:54ff:fe11:c119%16
Gateway predefinito . . . . . . . . . : 192.168.100.10
Server DNS . . . . . . . . . . . . . : 192.168.100.10
fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2

Scheda PPP Alice Adsl:

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Indirizzo fisico. . . . . . . . . . . : 00-53-45-00-00-00
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 82.55.114.137
Subnet mask . . . . . . . . . . . . . : 255.255.255.255
Gateway predefinito . . . . . . . . . : 82.55.114.137
Server DNS . . . . . . . . . . . . . : 85.37.17.51
151.99.125.1
NetBIOS su TCPIP. . . . . . : Disabilitato

Scheda Tunnel 6to4 Tunneling Pseudo-Interface:

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : 6to4 Tunneling Pseudo-Interface
Indirizzo fisico. . . . . . . . . . . : 52-37-72-89
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : 2002:5237:7289::5237:7289
Gateway predefinito . . . . . . . . . : 2002:836b:213c:1:e0:8f08:f020:8
2002:d5fe:20d:1::1
2002:836b:213c::836b:213c
Server DNS . . . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS su TCPIP. . . . . . : Disabilitato

Scheda Tunnel Automatic Tunneling Pseudo-Interface:

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Indirizzo fisico. . . . . . . . . . . : 52-37-72-89
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : fe80::5efe:82.55.114.137%2
Gateway predefinito . . . . . . . . . :
Server DNS . . . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS su TCPIP. . . . . . : Disabilitato

Scheda Tunnel Automatic Tunneling Pseudo-Interface:

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Indirizzo fisico. . . . . . . . . . . : C0-A8-00-01
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : fe80::5efe:192.168.0.1%2
Gateway predefinito . . . . . . . . . :
Server DNS . . . . . . . . . . . . . : fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2
NetBIOS su TCPIP. . . . . . : Disabilitato

Scheda Tunnel Automatic Tunneling Pseudo-Interface:

Suffisso DNS specifico per connessione:
Descrizione . . . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
Indirizzo fisico. . . . . . . . . . . : C0-A8-64-0A
DHCP abilitato. . . . . . . . . . . . : No
Indirizzo IP. . . . . . . . . . . . . : fe80::5efe:192.168.100.10%2
Gateway predefinito . . . . . . . . . :
Server DNS . . . . . . . . . . . . . : fec0:0:0:ffff::1%3
fec0:0:0:ffff::2%3
fec0:0:0:ffff::3%3
NetBIOS su TCPIP. . . . . . : Disabilitato


Il notebook (nonché il secondo pc), ha assegnato come ip: 192.168.0.3.

Se pingo da 192.168.0.1 a 192.168.0.3 RISPONDE
Se pingo da 192.168.0.3 a 192.168.0.1 RISPONDE

Se pingo da 192.168.0.1 a ns1.tin.it RISPONDE
Se pingo da 192.168.0.1 a 212.216.172.62 RISPONDE

Se pingo da 192.168.0.3 a ns1.tin.it NON RISPONDE
Se pingo da 192.168.0.3 a 212.216.172.62 NON RISPONDE


Su entrambi i pc c'è Windows XP Professional Service Pack 2.


Qualcuno mi sà dare una mano?

Dimenticavo, la condivisione della connessione internet l'ho abilitata per la scheda di rete che ha come ip 192.168.100.10, ho provato anche a metterla per 192.168.0.1, ma nulla è cambiato: il risultato è rimasto invariato.

Anche seguendo la configurazione automatica di windows (per la rete), il risultato è lo stesso: Internet non va in condivisione.

Ho provato a disabilitare il firewall di windows, ad abilitarlo con l'eccezione su UPnP Framework, ma nulla...!


Aiuto...

Mongi
10-07-2005, 19:32
stesso problema...circa...ma nessuno aiuta?

Larry
10-07-2005, 20:50
Domanda banale: sul (o sui) PC che sfrutta la condivisione della connessione ad Internet, avete impostato DNS e gateway predefinito con l'indirizzo IP del PC che condivide la connessione?

masterix21
13-07-2005, 04:11
Larry, risposta ancora più banale, ho provato a pingare l'ipv4 e non risponde. Se fosse problema di DNS, non risolverebbe gli indirizzi, ma l'ipv4/ipv6 dovrebbe rispondere, o almeno teoricamente questo dovrebbe accadere.

Comunque, il problema l'ho parzialmente risolto.

La condivisione della connessione Internet avviene solamente se il computer principale, al quale è connesso il modem Ethernet ADSL, viene acceso prima di tutti e la connessione parte dopo che i computer si sono trovati nella rete.
Quanto detto viene confermato dal fatto che se collego il notebook, nonché computer secondario, al pc principale quando quest'ultimo è già accesso e connesso ad internet, la connessione non viene condivisa. Non capisco perché accade ciò.

Qualcuno ne sa qualcosa? è un bug di WinXP Pro SP2?

masterix21
13-07-2005, 04:16
Larry, risposta ancora più banale, ho provato a pingare l'ipv4 e non risponde. Se fosse problema di DNS, non risolverebbe gli indirizzi, ma l'ipv4/ipv6 dovrebbe rispondere, o almeno teoricamente questo dovrebbe accadere.

Comunque, il problema l'ho parzialmente risolto.

La condivisione della connessione Internet avviene solamente se il computer principale, al quale è connesso il modem Ethernet ADSL, viene acceso prima di tutti e la connessione parte dopo che i computer si sono trovati nella rete.
Quanto detto viene confermato dal fatto che se collego il notebook, nonché computer secondario, al pc principale quando quest'ultimo è già accesso e connesso ad internet, la connessione non viene condivisa. Non capisco perché accade ciò.

Qualcuno ne sa qualcosa? è un bug di WinXP Pro SP2?

masterix21
21-07-2005, 04:15
UP UP UP UP ... il problema permane (della connessione funzionante solo se si avvia prima l'hub...)

masterix21
21-07-2005, 04:22
UP UP UP UP ... il problema permane (della connessione funzionante solo se si avvia prima l'hub...)

masterix21
21-07-2005, 14:42
Ho trovato una via di mezzo per risolvere il problema...

In pratica, aprendo la finestra Servizi di WindowsXP, basta riavviare 2 servizi (cioè quello relativo all'ICS e quello relativo al firewall), ed il problema si risolve. Come per magia la connessione si auto-ristabilisce e parte la condivisione Internet nella rete: il tutto senza riavviare l'hub.


Queste sono le cose strane dello zio bill...!

masterix21
10-08-2005, 07:37
Rettifico, basta riavviare il servizio del firewall di windows e funge tutto alla perfezione!

Loading