PDA

Visualizza la versione completa : Upgrade da sarge a sid, come?


fede_pg
05-07-2005, 11:50
Ciao, vorrei fare l'upgrade da sarge a sid.

C'è qualcuno che ha un link ad un howto decente in rete (ho cercato un po' ma nisba!) o che mi può dare qualche info?

Grazie :)

_sys/sid
05-07-2005, 11:51
in /etc/apt/sources.list sostituisci i mirror stable con unstable

Un Qualcosa del Genere... (non so' se la linea funziona)


deb http://ftp.us.debian.org/debian/ stable/update main

fede_pg
05-07-2005, 11:53
Così semplice? :D

Poi da shell con apt basta fare un aggiornamento?

_sys/sid
05-07-2005, 11:55
si... poi da shell fai


# apt-get update
# apt-get dist-upgrade

francofait
05-07-2005, 12:55
Originariamente inviato da _sys/sid
si... poi da shell fai


# apt-get update
# apt-get dist-upgrade


Unico problema :
visto come son ancora malconce le repositri sid , unstable , experimental ed in parte ancora anche le etch , poi dai problemi che ti creano ti fiinisci.

Neon87
05-07-2005, 12:55
Devi mettere queste 2 linee dentro /etc/apt/sources.list

deb ftp://debian.fastweb.it/debian/ unstable main non-free contrib
deb-src ftp://debian.fastweb.it/debian/ unstable main non-free contrib

devi mettere unstable per sid, testing per etch e stable per sarge...

poi apri una shell e dai un

apt-get update
apt-get dist-upgrade

e per finire prega un po' perche' vada tutto a buon fine...

ciao!

andy caps
05-07-2005, 13:57
qualche problemino lo danno ma si risolve in genere con un apt-get -f install
o
dpkg --configure -a

a volte si deve forzre a sovrascrittura di un pacchetto


se metti anche questa riga ti mette kde 3.4.1
deb http://pkg-kde.alioth.debian.org/kde-3.4.1 ./


io l'ho fatto ieri e non ha dato problemi

fede_pg
05-07-2005, 14:41
alle 15.30 inizio l'update ... intanto grazie a tutti!

Tra un paio d'ore posto il risultato (quindi preparatevi a darmi una mano a rimettere in piedi la mia debian :D).

:ciauz:

andy caps
05-07-2005, 14:49
dpkg --configure -a

apt-get -f install

li devi dare certamente

qualche problemino d sovrascittura lo da sempre
se devi forsare qualche pacchetto dopo questi comandi poi

se da errori tipo per esempio

Unpacking sysv-rc (from .../sysv-rc_2.86.ds1-1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/sysv-rc_2.86.ds1-1_all.deb (--unpack):
trying to overwrite `/etc/init.d/rc', which is also in package sysvinit


devi forzare i pacchetti in questione con il comando (in questo caso ad esempio

dpkg -i --force-all /var/cache/apt/archives/sysv-rc_2.86.ds1-1_all.deb

fede_pg
05-07-2005, 16:20
Sembra essere tutto ok per ora :), ora sto installando anche KDE 3.4.1.

Spero di potermi godere in pace la mia Sid :zizi: .

Siete stati tutti molto gentili!

PS: Non ho avuto nessun problema con i pacchetti, nonostante avessi una installazione molto incasinata (nel senso che ho installato una marea di roba che mi serve per lavoro), mi unisco ai complimenti fatti da Mutato in un altro post al team di Debian.

Loading