PDA

Visualizza la versione completa : [Disperazione]Altro problema xAuthority su slack


IenaBellamy
06-07-2005, 23:46
Tempo fa,sulla mia splendida slack, quando tentai di avviare x (startx) da utente normale il sistema dava continui timeout e problemi di xAuthority dopodichè mi rispondeva con un laconico "could not start ksmserver".

Usavo kde e slack 10.0.
Da root tutto ok,si avviava perfettamente. Il problema fu risolto grazie a andy_caps che con un semplice
"useradd [NOMEUSER] -m -G users,wheel,audio -s /bin/bash "

risolse il tutto.Infatti era una questione di permessi.

Tutto bene fino a oggi.Stamattina tutto ok. X si avviava perfettamente da utente normale.Poi verso l'ora di punta,mezzogiorno,quando fa molto caldo (sarà il caldo a rendere la slack così stronza?) il CHAOS.

Avviando X da utente normale ecco che mi si presenta un errore simile al precedente:

Prima parte con una serie di:

xauth:timeout in locking authority file//.Xauthority
xauth:timeout in locking authority file//.Xauthority
xauth:timeout in locking authority file//.Xauthority



Poi x si pseudo-avvia presentandosi con questa serie di errori:




The following installation problem was detected while trying to start kde:

No write access to $HOME directory (/home/iena)

Kde is unable sto start.




e poi ancora una serie di:



Could not start ksmserver. Check your installation
kdeinit not found.
Could not attach to dcop server.



Ora,la mia perplessità è questa: perchè mai di punto in bianco si rifiuta di partire? Ultimamente ho installato pacchetti come k3b e flashplayer..controllando e risolvendo le dipendenze. Può essere questo che ha causato il crash?
Ovviamente vorrei risolvere questo problema e capire cosa ha scatenato il crash.



:bhò:

andy caps
07-07-2005, 00:47
:bhò: deve essere avvenuto qualche errore sul disco e ti ha montato il disco in sola lettura

in genere riavviando si sistema si sistema

hai provato se da root da lo stesso problema ?

IenaBellamy
07-07-2005, 00:50
no da root tutto ok andy :bhò:

ho riavviato piu di una volta ma la situazione non cambia.

Comincio a pensare che anche i computers sentano il caldo misto all'umidità e che quindi,ne soffrono :D

andy caps
07-07-2005, 01:05
:bhò:

prova a dare un cd /home
chown -R iena iena
per vederese se gli da di nuovo i permessi

altrimenti prova a creare un nuovo user e dopo esserti copiati i dati da /home/iena mettili di proprieta del nuovo user

Loading