PDA

Visualizza la versione completa : Cambiare scheda video


@less
07-07-2005, 11:37
Ho provato a configurare la scheda video diverse volte con diverse versioni di linux (XConfig,Yast).
Ho provato anche a utilizzare il tool di installazione dal sito dell' ATI per SUSE, senza funzionare. Ho preso anche la mandriva perchè è l'ultima versione, non funziona il 3d per la RADEON 9800SE.

A questo punto non mi resta che cambiarla, però senza perdere prestazioni o piu potente (e 3d funzionante con linux), consigli o qualcuno che gli funziona?

Aki
07-07-2005, 11:59
Originariamente inviato da @less
Ho provato a configurare la scheda video diverse volte con diverse versioni di linux (XConfig,Yast).
Ho provato anche a utilizzare il tool di installazione dal sito dell' ATI per SUSE, senza funzionare. Ho preso anche la mandriva perchè è l'ultima versione, non funziona il 3d per la RADEON 9800SE.

A questo punto non mi resta che cambiarla, però senza perdere prestazioni o piu potente (e 3d funzionante con linux), consigli o qualcuno che gli funziona?

hai modificato il file di configurazione (xorg.conf per Xorg)?

@less
07-07-2005, 12:05
:fagiano: In SUSE no, scusa l'ignoranza ma in mandriva che è una versione recente non capisco il problema.

Aki
07-07-2005, 12:13
Originariamente inviato da @less
:fagiano: In SUSE no, scusa l'ignoranza ma in mandriva che è una versione recente non capisco il problema.

beh il driver video mica è sempre lo stesso dovrai pur settarlo

nel file Xorg.conf, nella sezione della sk. video, che driver hai???

@less
07-07-2005, 13:05
Ho un po di problemi con il pc e ho formattato la partizione linux. :stordita: Con knopppix è la stessa cosa?

(In questo momento non ho il mio pc)

Aki
07-07-2005, 13:06
Originariamente inviato da @less
Ho un po di problemi con il pc e ho formattato la partizione linux. :stordita: Con knopppix è la stessa cosa?

(In questo momento non ho il mio pc)

sinceramente non saprei perchè non ho mai provato, ma a logica direi proprio di sì

@less
07-07-2005, 14:11
Ok ci provo, controllo Xorg.conf e cerco le istruzioni per questo file. Provo anche con la Suse o Mandriva e se ho dei problemi mi farò sentire.

Grazie! :ciauz:

@less
14-07-2005, 20:14
Allora, proseguo in questo 3D, ho reinstallato la SUSE 9.2 con il kernel versione 2.6.8, il file Xorg.conf:


# /.../
# SaX generated X11 config file
# Created on: 2005-07-10T02:05:49+0200.
#
# Version: 4.8
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "it"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 340 270
HorizSync 30-65
Identifier "Monitor[0]"
ModelName "SONY SDM-X72"
Option "DPMS"
VendorName "SNY"
VertRefresh 43-63
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 110.80 1280 1360 1496 1712 1024 1025 1028 1061
Modeline "1024x768" 65.26 1024 1080 1184 1344 768 769 772 796
Modeline "800x600" 38.85 800 832 912 1024 600 601 604 622
Modeline "640x480" 24.30 640 656 720 800 480 481 484 498
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "R350 AH"
BusID "1:0:0"
Driver "radeon"
Identifier "Device[0]"
VendorName "ATI"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection


Da windows riporto le seguenti informazioni:



Proprietà scheda video:
Descrizione periferica RADEON 9800 SERIES - Secondary
Stringa RADEON 9800 SERIES
Stringa BIOS 113-A05608-100 BIOS(BR#4002)
Tipo chipset RADEON 9800 SE AGP (0x4148)
Tipo DAC Internal DAC(400MHz)
Driver installati ati2dvag (6.14.10.6476)
Quantità memoria 128 MB


ATI Radeon 9800 SE (R350) Adattatore video
ATI Radeon 9800 SE (R350) Acceleratore 3D

Proprietà processore grafico:
Adattatore video ATI Radeon 9800 SE (R350)
Nome in codice GPU R350
Periferica PCI 1002 / 4148
Transistor 117 milioni
Tecnologia processo produttivo 0.15u
Tipo bus AGP
Quantità memoria 128 MB
Clock GPU 277 MHz
Clock RAMDAC 400 MHz
Pixel pipeline 4
TMU per pipeline 1
Vertex shaders 4 (v2.0)
Pixel shaders 1 (v2.0)
Supporto hardware DirectX DirectX v9.0
Pixel Fillrate 1108 MPixel/s
Texel Fillrate 1108 MTexel/s

Proprietà bus memoria:
Tipo bus DDR
Bus 128 bit
Clock reale 270 MHz (DDR)
Clock effettivo 540 MHz
Larghezza di banda 8640 MB/s



ATI Registers:
ati-00F8 08000000
ati-0140 0000002D
ati-0154 F0000000
ati-0158 31420042
ati-4018 00010011
ati-CLKIND-0A 01292804
ati-CLKIND-0B 48001600
ati-CLKIND-0C 0400BC30
ati-CLKIND-0D 00DF8002
ati-CLKIND-0E 0400BC00
ati-CLKIND-0F 00000000
ati-CLKIND-12 AA021212


Ho provato abilitare il 3d ma informa che la scheda video non supporta openGL. Suggerimenti?

Aki
14-07-2005, 20:22
Originariamente inviato da @less
Allora, proseguo in questo 3D, ho reinstallato la SUSE 9.2 con il kernel versione 2.6.8, il file Xorg.conf:


# /.../
# SaX generated X11 config file
# Created on: 2005-07-10T02:05:49+0200.
#
# Version: 4.8
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/Xhttp://www.wwe.com/11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "it"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
DisplaySize 340 270
HorizSync 30-65
Identifier "Monitor[0]"
ModelName "SONY SDM-X72"
Option "DPMS"
VendorName "SNY"
VertRefresh 43-63
UseModes "Modes[0]"
EndSection

Section "Modes"http://www.wwe.com/
Identifier "Modes[0]"
Modeline "1280x1024" 110.80 1280 1360 1496 1712 1024 1025 1028 1061
Modeline "1024x768" 65.26 1024 1080 1184 1344 768 769 772 796
Modeline "800x600" 38.85 800 832 912 1024 600 601 604 622
Modeline "640x480" 24.30 640 656 720 800 480 481 484 498
EndSection

Section "Screen"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "R350 AH"
BusID "1:0:0"
Driver "radeon"
Identifier "Device[0]"
VendorName "ATI"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

Ho provato abilitare il 3d ma informa che la scheda video non supporta openGL. Suggerimenti?

non sò bene per le ATI, ma sembra che il driver 'radeon' non supporti l'accelerazione; al suo posto prova a mettere 'ati' come driver

cmq sul sito non c'è un README x l'installazione dei driver in linux?

e comunque, hai installato vero i pacchetti per il supporto OpenGL?

@less
14-07-2005, 20:38
Guarda, ho scaricato (è da Aprile che ci sto provando) scaricato Xorg e Xfree dalla sezione Radeon, ho provato sia quelli vecchi che i recenti, e seguito le istruzioni. Infine ho provato l'autoinstallazione ma niente da fare.
Sul sito cè la radeon 9800PRO ma non la SE.
Quando non ha fuzionato ho fatto partire XFreeconfig e gli ho messo RADEON GENERIC, non mi vedeva neache la 9800!

Loading