PDA

Visualizza la versione completa : installazione pacchetti


nomida
10-07-2005, 19:51
Ciao ho un problema nell'installazione di due pacchetti
libxi-dev e libx11-dev(servono per installazione modem usb)


in pratica libxi-dv dipende da libx11-dev
e libx11-dev dipende da libxi-dev quindi non riesco a installarli

uso il commando dpkg -i nomefile


root@bessi:/home/matteo/Desktop/libgtk1.2-dev # dpkg -i libxi-dev_6.8.2-10_i386.deb
(Lettura del database ...
72603 file e directory attualmente installati.)

Mi preparo a sostituire libxi-dev 6.8.2-10 (con libxi-dev_6.8.2-10_i386.deb) ...Spacchetto il rimpiazzo di libxi-dev ...

dpkg: problemi con le dipendenze impediscono la configurazione di libxi-dev:
libxi-dev dipende da libx11-dev; comunque:

Il pacchetto libx11-dev non ancora configurato.
dpkg: errore processando libxi-dev (--install):

problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:

libxi-dev



root@bessi:/home/matteo/Desktop/libgtk1.2-dev # dpkg -i libx11-dev_6.8.2-10_i386.deb
(Lettura del database ...
72603 file e directory attualmente installati.)

Mi preparo a sostituire libx11-dev 6.8.2-10 (con libx11-dev_6.8.2-10_i386.deb) ...

Spacchetto il rimpiazzo di libx11-dev ...
dpkg: problemi con le dipendenze impediscono la configurazione di libx11-dev:

libx11-dev dipende da libxi-dev; comunque:

Il pacchetto libxi-dev non ancora configurato.

dpkg: errore processando libx11-dev (--install):

problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:

libx11-dev


Che combino?grazie ciao

andy caps
10-07-2005, 20:00
:bh: prova un apt-get -f install
oppure forza i pacchetti

dpkg -i --force-all libxi-dev_6.8.2-10_i386.deb
poi l'altro dovrebbe andare

nomida
10-07-2005, 20:03
ok grazie!!
il bello che anche qua lo si vede:http://packages.ubuntu.com/hoary/libdevel/libx11-dev
http://packages.ubuntu.com/hoary/libdevel/libxi-dev


adesso provo!!

Loading