PDA

Visualizza la versione completa : [Java] Problemi di compatibilità tra librerie


morphy79
12-07-2005, 11:52
uffaa... sto usando la jdk 1.3... per un motivo ancora misterioso ( direttive dall'alto ) non posso passare alla 1.4 o maggiore...

solo che per lavorare mi serve questa classe

java.util.prefs.Preferences

ma la libreria è mancante perchè parte proprio dalla 1.4...

non c'è un qualche jar... qualche class... qualcosa insomma che mi includa sta libreria ??? :confused:

cayman
12-07-2005, 12:04
Se hai da jdk 1.4 potresti estrarre la libreria dal file src.zip

Andrea1979
12-07-2005, 12:07
credo proprio che non sia solo questione di aggiungere il "jar" adatto, in quanto sono proprio funzionalità aggiuntive che comunque una JVM 1.3 non potrebbe gestire... ossia andresti contro alle specifiche richieste del tuo capo... però lascio la parola ai guru.

LeleFT
12-07-2005, 12:16
Anche secondo me non ha senso importare un eventuale JAR con la libreria richiesta, poichè la libreria stessa, per poter funzionare, richiede una JDK successiva a quella utilizzata.
Prova a cercare su Google se trovi una libreria equivalente adatta alla JDK 1.3 che utilizzi.


Ciao. :ciauz:

Loading