PDA

Visualizza la versione completa : Usbdevfs, Alsa ed altre amenità!


virusbye
14-07-2005, 13:39
Ciao a tutti,
ho convinto (leggesi costretto) un amico a mettere Ubuntu e ovviamente mi tocca configurargli tutto affinchè funzioni. Sfortuna vuole che non funzionino lo scanner, la stampante, il modem adsl e l'audio.

Tralasciando la stampante (che al momento è l'ultimo dei miei e suoi pensieri) e mettendo da parte per un attimo l'audio, ho cercato di configurare lo scanner, un AGFA SnapScan 1212U, collegato tramite USB. Sebbene su internet si trovino numerosissime guide, mi sono "bloccato" quando in una di queste guide ho trovato scritto di dover montare "/proc/bus/usb come usbdevfs".
Ho quindi modificato l'fstab, ed ho dato il comando "mount /proc/bus/usb" e qui ricevo un errore che mi dice che il tipo "usbdevfs" non è riconosciuto (o non è valido), insomma non è possibile montarlo.
Ho provato a fare il modprobe di usbcore, usb-storage, e tutto quanto è inerente l'usb ma non sono riuscito a montare sto benedetto device come "usbdevfs".
Come posso fare per abilitarlo?
Premetto che il sistema ha un kernel Ubuntu 2.6.10.

Per l'audio, invece capita una cosa stranissima, da root do il comando "alsaconf" che mi riconosce e mi setta correttamente la skd audio; finita la procedura, infatti, da Rhythmbox riesco ad ascoltare tranquillamente le canzoni.
Ricordandomi di aver risposto "si" quando l'alsaconf mi chiede di impostare l'audio all'avvio, riavvio bello beato il computer, accedo con l'utente, provo rhythmbox ma mi da l'errore "mixer OSS non trovato". Stupito apro il terminale, do "lsmod" e vedo che i moduli non sono caricati, rieseguo l'alsaconf, l'audio parte, e decido in maniera maccheronica di segnarmi i moduli caricati (altro lsmod) e di metterli a manina in /etc/modules.
Riavvio, apro rhythmbox e ricevo l'errore di prima di OSS, al che', apro il terminale, divento root e faccio
"lsmod > lsmod_prima.txt", poi alsaconf, poi "lsmod > lsmod_dopo.txt", provo l'audio funziona, guardo i due file lsmod_prima.txt e lsmod_dopo.txt e sono identici.
Assunto che non è un problema di moduli, può essere un problema di "alias"? mi spiego, spippolando in /etc/modules.d/audio ho trovato qualcosa tipo
"alias via82ecc snd-card0" (o qualcosa di simile).

Chi mi saprebbe dare una mano? sto impazzendo! :)

andy caps
14-07-2005, 14:39
per l'audio prova a mettere in /etc/modprobe.d/sound
alias snd-card-0 snd-via82xx
options snd-via82xx index=0
se non c'è

ultimamente con gli ultimi aggiornamenti l'audio è diventato un problema anche per me con la via integrata

per regolare l'audio devo farlo da aumix regolando pcm :master:
installa comunque i moduli di alsa e i vari aumix alsamixergui che spesso risolvono in qualche modo

per la stampante guarda qui
http://forum.html.it/forum/showthread.php?s=&threadid=855662&highlight=printconf

se risolvi
per usbdevfs devi avere il modulo statico o modulare inserito nel kernel
│ USB device filesystem

in alto nella sezione delle usb
altrimenti prova ad installare altre ai vari programmili per le usb devfsd ( se non combina pasticci protrebbe risolvere )


none /proc/bus/usb usbdevfs defaults 0 0
è la stringa che devi mettere in fstab non il comando

il comando sarebbe
mount -t usbdevfs none /proc/bus/usb

per lo scanner prova kooka di kde che va decisamente bene

Loading