PDA

Visualizza la versione completa : [debian] problema con locales


sopadj1
14-07-2005, 20:42
salve gente!
come da titolo ho questo problema :(

dpkg-reconfigure locales
mi da questo errore prima di avviare la grafica per la selezione dei locales



perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "it_IT@euro",
LC_ALL = "it_IT@euro",
LANG = "it_IT@euro"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory


poi, una volta selezionati i locales che voglio generare i quello di default mi da questo errore



Generating locales...
en_GB.ISO-8859-1...i18n:1: syntax error: not inside a locale definition section
i18n:2: syntax error: not inside a locale definition section
i18n:3: syntax error: not inside a locale definition section
i18n:4: syntax error: not inside a locale definition section
i18n:5: syntax error: not inside a locale definition section
/usr/sbin/locale-gen: line 41: 9410 Segmentation fault localedef -i $input -c -f $charset -A /etc/locale.alias $locale


chi mi aiuta?

grazie

andy caps
14-07-2005, 21:08
prova a installare aspel

apt-get install myspell-it aspell-it aspell-bin console-data

mykol
14-07-2005, 22:30
mi aggiungo anch'io perch sul mio notebook Acer Travelmate 507DX ho un problema analogo (pi complesso) sulla mia Kurumin di cui ho gi chiesto ieri in un altro post (francofait).

ero riuscito a mettere tutto a posto, ma a volte, al riavvio mi ritrovo le dir /usr/share/locale/it ed it_IT vuote ...

In genere copio al loro posto i locales presi da una knoppix in italiano rifaccio la configurazione con dpkg-reconfigure locales, dal centro di controllo di KDE scelgo la lingua e la tastiera italiane e tutto funziona. Ma stavolta nulla. Nel campo con tutte le lingue Italiano non compare, ma compare nel campo di destra. Se seleziono italiano, lo sposto in prima posizione in alto e clicco su apply non compare nell'apposito campo. Il campo soprastante (paese) vuoto e non c' nulla da scegliere. Tutti i campi (anche le bandierine a fianco alle lingue) sono in bianco e nero (mancano i colori) come anche sul pulsante sulla barra.

Ho installato myspell-.... console-data ecc.... ho fatto le riconfigurazioni (anche dpkg-reconfigure console-data) ma nulla, la situazione non cambia. Sono riuscito ad installare una tastiera italiana, ma # @ ] [ non compaiono (il tasto ALT GR inattivo).

Cosa mi pu mancare ?

Soluzioni ?

Pu dipendere da qualcosa nella home dell'utente (ieri l'ho spostata ...)

Non so pi cosa pensare e fare ...

Grazie ancora

andy caps
14-07-2005, 22:37
per kde devi installare kde-i18n-it oltre ai dizionari

dai un apt-get --reinstal install kde-i18n-it
se perde i pezzi :madai!?:

sopadj1
14-07-2005, 23:15
Originariamente inviato da andy caps
prova a installare aspel

apt-get install myspell-it aspell-it aspell-bin console-data

grazie ora provo

Loading